Mvn Clean with SDK

So after I run a mvn clean install with changes to code on the SDK project, I get this ERROR. Ideally my work around this would be to restart my machine, then I would build again normally.

I noticed that, if I keep on building the project even without any changes to code, I would get the same failure and repeat the sequence of restarting.

Anyone with an idea for an easier workaround or reason why this actually happens? @dkayiwa @raff @mozzy

just cant see any logs on the haste bin link you dropped

Can u please try to skip tests by typing the running the following command mvn clean install -DskipTests

Please even specify the JDK you are Using because it might be of help :roll_eyes:

Even try to see the issue might be with your MYSQL.

@herbert24 try to reload again


I tried skipping tests too and had a successful build, I may not always need to skip tests too. The Java version and MySQL is all well set, shouldn’t be an issue

1 Like

It seams you are using oracle JDK 8, why dont you try OpenJDK 8 and see, you never know?

@odorajonathan you are not building a correct thing,you need to build a module and then deploy the .omod into the sdk modules folder,after start the sdk