mvn build error

The method getMemoryAppender() in class org.openmrs.util.OpenmrsUtil is missing. I have cloned the repo afresh and i still get the same compilation error on the master branch. Please advise on the way forward.

@dkayiwa,@jwnasambu, @kdaud

Well, that is encouraging. @gracebish, you will get the same results as long us you are cloning from the same fork(not unless you deleted the repo and fork afresh). Besides, you pulled the changes and it shows the content is up-to-date. I am getting an error too though different form yours i run git config --global alias.up "pull --ff-only --rebase --autostash". command ( which keeps a clean history and tries to reapply your changes) followed by mvn clean install and this is my output I believe @ibacher can be of help on the way forward.

1 Like

@gracebish So the problem is that in 2.4.0, this method got added, but the 2.4.0 OMOD for the REST web services relies on 2.4.0-SNAPSHOT. Most likely, your local Maven cache has a version of 2.4.0-SNAPSHOT that was compiled before that method was added in. Probably the easiest fix is to change this line in the omod-2.4/pom.xml file to:


I.e., switch it from using the SNAPSHOT to using the actual released version.

PS I’ve made that change to the main branch of the repo, so you could just do a git update and get the change that way.

1 Like