mvn build error

I get this compilation failure when i run mvn.

Please advise on the way forward.

@dkayiwa, @jwnasambu, @herbert24

you can also explain here what module you are trying to build and steps you tried,am seeing you are running the webservices module,did you first pull the latest changes to your repo?

@gracebish you are getting cannot find symbol error because you are trying to use a variable without declaring it and to solve it you need to import org.openmrs.util.MemoryAppender;

1 Like

@gracebish use git pull --rebase upstream master and build again,the module runs well at my side this is after using that command,make sure you added an upstream

1 Like

I consent with you @herbert24 . @gracebish I thought the error you shared was after you have made the changes and you were ready to make a commit. Since you haven’t made any changes, kindly follow the steps @herbert24 has shared above.

1 Like

@jwnasambu, i have followed the same steps but the error already exists in the master branch. So it causes a build failure on Rest Web Services 2.4 OMOD

What does git remote -v returns

It returns origin (fetch) origin (push) upstream (fetch) upstream (push)

do a git pull --rebase upstream master,and build again using mvn clean install

As @herbert24 has mentioned, do git pull --rebase upstream master followed by mvn clean install and share the experience. Ensure your internet connection is ok

Well, I will request you also try out. I have just cloned from my fork and when I run mvn clean install command I get this error JULIE@JULIE-PC MINGW64 ~/OpenMRS-Tickets/ ()$ - both on Git Bash and command prompt though different from @gracebish

@jwnasambu ,The real problem is line 20. The method getMemoryAppender() is undefined for the type openmrsUtil. May be we need to create a ticket for this.

Have run the module locally and all the tests are passing.
git reset --hard upstream/master
and then
git pull upstream master
Build the module again and share the experience

Have you tried out and the build is successful?

@kdaud, please try it out and give feedback. It still brings up the same build failure.

The module runs successfully. Am suggesting @gracebish to do git reset --hard upstream/master and also git pull upstream master . Build the module again

@kdaud, Thank you. Let me try again now.

Share the outcome

@kdaud, the problem has persisted

Then the error is caused by compiler incompatibility with the module. What output is displayed by these commands
mvn -v
java -version

javac -version