Missing a fork on github

I am trying to clone a fork from github and it gives me results for the previous ticket which i worked on earlier. Any advise on how to handle?? @mozzy, @reagan, @gcliff

@gracebish what are the results your talking about? …you can share them

Te results displayed on eclipse, where i am supposed to make changes from, are the ones for a previous ticket.

@gracebish 1. You don’t have to keep cloning ur fork Everytime your working on a new ticket. Git bash is a good tool that allows you navigate between branches 2. Using the cloned repository you already have on your PC… Go to git bash and just make sure your on the master branch otherwise you can run a command like git checkout master followed by creating a branch


@gracebish what tool are you using for navigating and creating branches ? ,i would recommend git bash just like @reagan has suggested earlier on,tryt to create a new branch off the master branch you cloned every time your working on a different ticket by using git checkout -b <branch name/ticket id> and switch to the new branch using git checkout <branch name/ticket id>.

you can also have a look at https://wiki.openmrs.org/display/docs/Using+Git


1 Like

Thanks for the guidance

1 Like

Thanks for the continued support. I am still stuck even after following different ideas. after creating a branch on gitbash, when i get to import existing maven projects, i still get a different ticket. Could there have been a problem with the fork? Or there are some steps that are not clearly outlined on our wiki? Surely, i have tried to read and re- read all materials on our wiki and followed different you tube videos, but still stuck. Can someone help? @gcliff, @reagan, @ibacher

Sorry about this. Did you delete the openmrs-core repository you cloned when you were working on the first ticket? if you didn’t you don’t have to import the project again but just switch to a new branch using git bash with the command git checkout -b TRUNK-5115

@gracebish it would be good if u share ur commands and logs that ur trying out such that we can know how to help best using pastebin.com

@gracebish was your issue sorted out?

1 Like

Adding on other comments, i think this may be working directory issue, you may have either deleted your repository or not , if you are actually not well with using git bash commands, feel free to use eclipse, eclipse has similar GUI commands, You can also try sharing your eclipse working environment and steps where you are stuck