MF-434 Make Logo spot configurable (could be text, image, etc)

I have encountered this error while downloading the dependencies of the repository. I installed npm using command sudo apt install nodejs npm, and my nodejs version is 10.19.0. Can someone help me with it?

Thank you

The problem is related to npm’s cache that got corrupt. However in newer versions, self healing was implemented to solve the issue but ita not efficient at times. Try :

npm cache clean --force

And then :

npm install -g (your dependencies)

For more bout npm cache, refer to this

Thank you Herman! I get a lot of warnings after running the first second command, and then I run the npm install command again. I seems it works this time, but it says I need to download the peer dependencies manually. I am kind of confused about how to do it. Could you help me? The page you sent seems to be missing for me. Here is the pastebin warnings zoe@zoe-VirtualBox:~/openmrs-esm-primary-navigation$ npm cache clean --forcenp -

1 Like

Look through your cloned directory and delete node_modules directory and reinstall packages by npm install

I have tried the steps you gave me and I got those warnings saying that I need to install the peer dependencies myself. I am not sure if this works? If I need the peer dependencies, how should I download them? Thank you!

Whats the version of your npm coz if its below v7 then you need to upgrade it to 7 so as to install the dependencies automatically. peerDependencies are not installed by default with prior npm versions, developers needed to manage and install their own peer dependencies.

npm install -g npm@7 - To upgrade your npm version to @7 After that I think you should be able to npm i

And endeavour to utilise sudo su- to bypass the permissions error

1 Like

I got this error message zoe@zoe-VirtualBox:~$ npm install -g npm@7npm WARN checkPermissions Missing wr - from running the above command. It seems I do not have write access to the directory. Command sudo su- does not work for me as the command was not found. I also tried running sudo su- npm install -g npm@7, and sudo npm install -g npm@7. However, my npm version is still 6.14.4.

Follow the steps here How to fix the "Missing write access" error when using npm

1 Like

Thank you Herman! I think it went through.

1 Like