Mandatory Reference app/modules to access OpenMRS UI in local (while running Core/Platform: openmrs-core)


I am able to install OpenMRS application using SDK and using Reference Application 2.8.0.

As per our requirement, I am trying to setup the OpenMRS from Core module. Can somebody help me identifying the Mandatory modules that are required to access the UI.

When I run the Core module, im getting the error: no user interface module is installed

@vamsioptum I don’t remember from the top of my head, but when you do this:

mvn openmrs-sdk:setup -DserverId=platform-2-1-4 -Dplatform=2.1.4 -DdbUri=jdbc:mysql://localhost:3306/openmrs_platform-2-1-4 -DdbUser=root -DdbPassword=root

Does it install only OpenMRS Core, or also the platform modules?

P.S. Of course you must adapt -DdbPassword=root.

When we setup using SDK it installs modules also.

Can you list them here?

ls -lh ~/openmrs/platform-2-1-4/modules

Hopefully something like this is part of it: legacyui-*.omod. That’s the one that brings the legacy UI.

  • Atlas Module

  • Form Entry App Module

  • Reporting

  • Metadata Sharing

  • ID Generation

  • Allergy UI Module

  • EMR API Module

  • Registration App Module

  • HTML Form Entry UI Framework Integration Module

  • App Framework Module

  • Reporting REST

  • Reference Metadata Module

  • Metadata Mapping

  • Admin UI Module

  • OpenMRS UI Framework

  • Reference Application Module

  • App UI Module

  • Metadata Deploy

  • Reporting Compatibility

  • HTML Widgets

  • Serialization Xstream

  • Address Hierarchy

  • Registration Core Module

  • Core Apps Module

  • Event Module

  • Provider Management Module

  • Chart Search Module

  • Calculation

  • Appointment Scheduling UI Module

  • Open Web Apps Module

  • FHIR Module

  • HTML Form Entry

  • UI Commons Module

  • Rest Web Services OMOD

  • Reporting UI Module

  • Appointment Scheduling Module

  • Legacy UI Module

  • Data Exchange Module

  • UI Library Module

  • Reference Demo Data Module

    • List item

Those are the Ref App modules, not the Platform modules. Did you actually run the command that I provided earlier in the thread?

oh…ok. Actually I tried this command to setup SDK - mvn org.openmrs.maven.plugins:openmrs-sdk-maven-plugin:setup-sdk


I could not able to run the commands you provided.

mvn openmrs-sdk:setup -DserverId=platform-2-1-4 -Dplatform=2.1.4 -DdbUri=jdbc:mysql://localhost:3306/openmrs_platform-2-1-4 -DdbUser=root -DdbPassword=admin

Im getting the errors:

[ERROR] Failed to execute goal org.openmrs.maven.plugins:openmrs-sdk-maven-plugin:3.13.2:setup (default-cli) on project standalone-pom: Failed to setup server: Unable to execute mojo: Unable to resolve artifact. Could not transfer artifact org.openmrs.web:openmrs-webapp:war:2.1.4 from/to openmrs-repo ( PKIX path building failed: unable to find valid certification path to requested target [ERROR] org.openmrs.web:openmrs-webapp:war:2.1.4

I have the Core module setup and is up and running.

Can somebody please help me identifying the Mandatory modules that are required to access the UI.

Try this instead then, this will install Platform 2.1.3:

mvn openmrs-sdk:setup -DserverId=platform-2-1-3 -Dplatform=2.1.3 -DdbUri=jdbc:mysql://localhost:3306/openmrs_platform-2-1-3 -DdbUser=root -DdbPassword=root

Last time I gave you the command for Platform 2.1.4 assuming it would be available to the SDK.

Hi Dimitri,

I installed Platform 2.1.3. It only installed the platform modules (openmrs-core) and it didn’t install the reference app modules. The modules folder is empty and when I tried to access the application i’m getting the same error as earlier.

What’s the output of

ls -lh ~/openmrs/platform-2-1-3/modules

The folder is empty.

Ok so what this says is that installing a so-call platform distro only installs the Core…

I think at the end of the day you only need to install the Legacy UI module.

Since you have installed a Ref App distro already, just copy that module under ~/openmrs/platform-2-1-3/modules and start the server again.

oh…ok. let me try that.

Thank you so much!!

Its working, I’m able to access the UI.

And I have one more doubt, As we did the setup using SDK its working fine.

But does it work if I checkout the openmrs-core platform code from Git and run from eclipse IDE and copy the Legacy UI module in the modules folder?

I would not recommend to run it from Eclipse, I would run it 1) in debug mode with the SDK and 2) connect a remote debugger from Eclipse.

1) Run the server with debug port 58080

mvn openmrs-sdk:run -Dport=8080 -Ddebug=58080 -DserverId=platform-2-1-3

2) Setup a remote debugger on port 58080


Don’t forget to add the cloned Core’s sources to the ‘Remote Java Application’ ‘Source’ tab.


Thank you so much!!

How to add cloned Core’s sources to the ‘Remote Java Application’ ‘Source’ tab?