Location of file uploaded from HTML form?


I am working on adding a feature to upload files via HTML forms

I followed the instructions on this wiki page https://wiki.openmrs.org/pages/viewpage.action?pageId=36668565

I managed to integrate the upload feature yet I was unable to see the uploaded file.According to the wiki page just embedding the code snippet I will be able to upload files as patient records.yet I am unable to find the uploaded files(Actually the files that I tried to upload by selecting).

Is there any change that I need to do in order to upload files. Or am I missing something here?

Please be kind enough to give me some light here.

Hmmm… After looking through the documentation at https://wiki.openmrs.org/pages/viewpage.action?pageId=36668565, i’m afraid that I can’t figure out where the uploaded forms are supposed to be saved either… :frowning:

The uploaded files are stored as complex observations within OpenMRS. I forget exactly where they end up within the file system, but hopefully the documentation on complex obs will provide the answer:


1 Like


@nipun Thanks, you were correct and at the same time I was correct, the problem I had was I could not upload, so Looked carefully on how to concept for uploading, it seems I have not set the classs to Misc(I am still not sure what this is yet), then it was uploaded fine :slight_smile:

Thanks :smiley:

@akshika47, Wonder if concept class has anything to do with the image upload. btw did you try image uploading with appframework? The same form doesn’t work when accessed via Clinician facing Dashboard’s link.Home>Find Patient Record > Patient > Form (though it says saved successfully, data never reach the DB), but works fine if you access it via old interface (Home>Form Entry>Select Form).

I did not try. I will check and let you know. :confused:

@mogoodrich this is one problem :slight_smile:

@akshika47 it’s unclear to me what the current state of the issue is? If you set the class to “Misc” do things work?

@mogoodrich : well initially it was not working for the older version either, after setting the class to misc, it worked for the older version, but it does not work with the RefApp. Can you tell me how to get it working in the RefApp?

Unfortunately, I’ve never tried to upload an ah image with the RefApp. I see that @arbaughj has laid out clear steps to reproduce… can you start to debug and see what you find?


The ticket identifying the Reference App file upload bug and steps how to reproduce it is at… https://issues.openmrs.org/browse/RA-961