Lastest build of LegacyUI doesn't produce a user interface

After compiling the current version of the Legacy UI module and then dropping the resulting omod in /home/ash/.OpenMRS/modules I restart the web application (running in Jetty via Eclipse) but I am still presented with the page that reads:

“If you are seeing this page, it means that the OpenMRS Platform is running successfully, but no user interface module is installed.” etc.

What are possible causes of this? Are there compatibility problems between the latest version of openmrs-core and the legacy-ui module?

I’m new to this project and I would like to start tackling some simple bugs etc is latest build of OpenMRS-core + legacy ui module a good base to start from? Any advice greatly appreciated.

1 Like

Is there anything helpful in the logs?

I’m having the same problem as you!

Specifically, if I run openmrs-core with only the legacyUI module in the modules folder, it runs. However, once I add a couple more modules into the folder the legacyUI stops loading.

Without sharing what you have in the logs, we cannot be of help. :smile:

Now I get a 500 error with the following details when I try to load localhost:8080

PWC6197: An error occurred at line: 17 in the jsp file: /WEB-INF/tags/module/legacyui/url.tag
PWC6199: Generated servlet error:
package org.openmrs.web.taglib does not exist

The last few entries in OpenMRS.log are as follows…

WARN - SimpleUrlHandlerMapping.registerHandlers(115) |2016-03-07 20:44:06,522| Neither 'urlMap' nor 'mappings' set on SimpleUrlHandlerMapping
INFO - ServiceContext.doneRefreshingContext(842) |2016-03-07 20:44:06,534| Done refreshing Context
WARN - OpenmrsUtil.getRuntimePropertiesFilePathName(2109) |2016-03-07 20:44:06,964| Unable to find a runtime properties file at /home/ash/development/openmrs-core/webapp/

Can you share the full log?

You need to share your logs, do you have other module installed?

I don’t seem to see anything helpful in the logs though i see this:

In method AdministrationService.saveGlobalProperty. Arguments: GlobalProperty=property: legacyui.started value: true,

Which indicates that the module started

I’m not sure if this will help, but here is the output from the server when I start openMRS with the legacyui module, along with the reference application and supporting modules present in the modules folder. The legacyui will work as long as I don’t have more than 1 or 2 extra modules in the module folder with it.

Edit: I’m aware that the reference application doesn’t currently run. However, the error seems to still be present with any additional modules, not just the reference application module.

1 Like

Looks like you have other installed modules that are breaking things, several module don’t work with Platform 2.0 yet, you might want to install their latest builds, if you stop all the other modules i believe you will see the legacy UI

I have been able to resolve my issues. I think it either hadn’t compiled properly or there was an issue with the way I was running Jetty from Eclipse. Starting from scratch and making sure the correct JRE was selected in both Eclipse and also the JRE tab when setting up the Run As configuration for Jetty has resolved the issue.

@ashleyevans, @cards31 I just experienced this same error. I had no other modules installed, and am pretty sure i followed the instructions right. But i noticed that only the home page is not working. When I enter the link http://localhost:8080/openmrs/admin/index.htm, i am requested to login, when i login, i see the admin and other pages fine, but when i go back to home page by clicking on the home tab, i see the default platform page again. Still investigating why this is happening, but this should be a work around for anyhow blocked. :slight_smile: