Issues with .87 upgrade

Hello, as I am reconfiguring and retesting, I am finding a few things that I could use some direction with.

  1. There is no longer access to “Date of Death/Reason/Is dead”. Are they now defaulting to hidden? I looked in configuration files but was unable to locate the issue.

  2. I’m receiving the following error when saving from this page:

  3. There is no longer access to the Orders or Medications tabs from the Consultation dashboard.

    Have they been move somewhere else?

Thank you for your assistance! Denise Nelson

1 Like

Hi @dnelson

Can you please check your config to confirm that its not overridden. And can you check the permissions as well?

And can you check the permissions as well?

I think one needs to have the “Consultation-Treatment” role to be able to see that tab. https://bahmni.atlassian.net/wiki/pages/viewpage.action?pageId=48889893

But, it might likely be that your configuration doesn’t have the Tab. Please check. Let us know what you find. You can paste your configuration content otherwise here.

This is because death concept is not configured correctly. Adding Fully specified name of the Concept set under openmrs global property “concept.reasonForDeath” solved the issue.

Problem with obs validator. Upgrading to latest fixed the issue. Yet to investigate why this is happening.

This is because the mentioned privileges are not present. Adding relevant privileges for the corresponding sections in clinical/extension.json solved this issue.