Installation for Developers on windows

When i run the command “mvn jetty:run” after following all above instructions mentioned on page i get [ERROR] No plugin found for prefix ‘jetty’ in the current project and in the plu gin groups [org.apache.maven.plugins, org.codehaus.mojo] available from the repo sitories [local (C:\Users\amar.m2\repository), openmrs-repo (http://mavenrepo.o, central (https://repo.maven.apach] -> [Help 1]. Please help me.

Did you check to make sure you are executing the command inside the right directory? I mean inside openmrs-core/webapp and not within /openmrs-core ?

1 Like

Yes i did that in openmrs-core webapp only.Next what i tried was to delete’.m2>org>openmrs’ and build the .war file and dependencies again but now i’m getting [ERROR] Failed to execute goal on project openmrs-api: Could not resolve dependencies for project org.openmrs.api:openmrs-api:jar:2.1.0-SNAPSHOT: Failed to collect dependencies at org.openmrs.liquibase.ext:modify-column:jar:2.0.2: Failed to read artifact descriptor for org.openmrs.liquibase.ext:modify-column:jar:2.0.2: Could not transfer artifact org.openmrs.liquibase.ext:modify-column:pom:2.0.2 from/to openmrs-repo ( Unknown host -> [Help 1]

Do the following, if it doesn’t work, ping me on irc

  1. ensure you have good internet
  2. delete the whole of .me directory and not just the .m2/org/openmrs
  3. cd openmrs-core and run mvn clean install
  4. cd webapp and run mvn jetty:run

That is not very clear. Instead of saying you built the .war and dependencies, show me the commands you used and how you used them. Take a snapshot of your terminal so I can see what you are doing. You can make a gif or something.

1 Like

Thanks a lot for your advice I was able to build and deploy the .war file after deleting .m2 directory.Thanks once again.

1 Like

You are welcome. Am glad you were able to build :smile: