Installation error of bahmni on CentOS 7

hello community, currently, I have a project on the installation of Bahmni version 0.90 on CentOS 7. But, during the installation, after typing the command: bahmni install, I receive the following error:

root@Bahmni ~]# bahmni install
ansible-playbook -i /etc/bahmni-installer/local all.yml -vv  --extra-vars '@/etc/bahmni-installer/rpm_versions.yml' --extra-vars '@/etc/bahmni-installer/setup.yml'
/bin/sh: /bin/ansible-playbook : /usr/bin/python2.6 : bad interpretor : no file or type of this documents
Traceback (most recent call last):
  File "/bin/bahmni", line 11, in <module>
    load_entry_point('bahmni==0.1', 'console_scripts', 'bahmni')()
  File "/usr/lib/python2.7/site-packages/click-6.7-py2.7.egg/click/", line 722, in __call__
    return self.main(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/click-6.7-py2.7.egg/click/", line 697, in main
    rv = self.invoke(ctx)
  File "/usr/lib/python2.7/site-packages/click-6.7-py2.7.egg/click/", line 1066, in invoke
    return _process_result(sub_ctx.command.invoke(sub_ctx))
  File "/usr/lib/python2.7/site-packages/click-6.7-py2.7.egg/click/", line 895, in invoke
    return ctx.invoke(self.callback, **ctx.params)
  File "/usr/lib/python2.7/site-packages/click-6.7-py2.7.egg/click/", line 535, in invoke
    return callback(*args, **kwargs)
  File "/usr/lib/python2.7/site-packages/click-6.7-py2.7.egg/click/", line 17, in new_func
    return f(get_current_context(), *args, **kwargs)
  File "build/bdist.linux-x86_64/egg/", line 91, in install
  File "/usr/lib64/python2.7/", line 542, in check_call
    raise CalledProcessError(retcode, cmd)
subprocess.CalledProcessError: Command 'ansible-playbook -i /etc/bahmni-installer/local all.yml -vv  --extra-vars '@/etc/bahmni-installer/rpm_versions.yml' --extra-vars '@/etc/bahmni-installer/setup.yml'' returned non-zero exit status 126
[root@Bahmni ~]# 

please help me. Thank you.


From Install Bahmni on CentOS:

For Production purposes, CentOS 6.9 64bit is the recommended & tested platform for running Bahmni server. If you want to install Bahmni for production or staging environment on a CentOS 6.9, then you can follow the steps mentioned here.

CentOS v7 is currently not certified for Bahmni.

We do have it on this year’s workplan to support CentOS 7. I will make sure we create a JIRA ticket for this and share the link here.

Thanks Mister Darius.

Thank you Sir for your prompt return. I have an Asus Desktop G11CD Intel Core i7 that I want to use as a development environment to familiarize myself with the implementation and development of Bahmni.

When I tried to install CentOS 6.8 on it, I had the following error message: Detected CPU family G model 158. My research on the centOS bug database showed me through the following link: showed to use version 7.4 .1708 in order to install CentOS. Following the successful installation of CentOS version 7.4.1708. I could not install Bahmni 0.90 . I am getting the error message i posted early. Would it be possible to fix the issue and get bahmni 0.90 installed on CentOS v7 for training purpose given the fact that my current computer cannot install CentOS 6.8.
Thank you in advance for your help.

@diallo having Bahmni run on CentOS 7 is a large task, and while we do intend to work on it this year, it cannot happen quickly. The JIRA ticket is here if you want to follow:

Have you tried CentOS 6.9, which is the recommended & tested platform for Bahmni?

If not, you may need to try running Bahmni on Vagrant (which is also documented on the wiki).