ID shenanigans on the past two days

For the past two days, it appears that OpenMRS ID was refusing to let certain people login. JIRA and Confluence login were unaffected.

I had to restore a backup, but due to how our ID subsystem works, I do believe nothing was lost. If you create a user on the last two days or were granted access to JIRA/Wiki and lost data, please let me know.

I’m still waiting for confirmation that the problem is now solved.

cc @jwnasambu

Am now able to log in. Thank you so much @cintiadr :smile:

@cintiadr its ok with me.

@cintiadr could this problem have switched to JIRA?

I was already logged in. Then i saw two help desk requests for people who are not able to log in JIRA yet they were doing so last week. So i logged out of my account and tried to log in again. Lo and behold, i got into the same exact problem. With an error message “Sorry, an error occurred trying to log you in - please try again.”

No, it couldn’t.

The problem with mongodb could not have possibly affected login with JIRA, because they are not related at all.

But it appears to have a problem with our LDAP, trying to fix and bring news.

Next time, use a incognito mode or a different browser to test, so you do not lock yourself out :slight_smile:

1 Like