I cannot see concept name in local language!!?

Hi I’m implementing bahmni in Thailand and I have issue with concept name local language. I’m not whether I did something wrong.

for example

I change concept name(“teaspoon”) and short name(“teaspoon”) in local language like this

but when i enter medication tab in unit dropdown field there are no “ช้อนชา” instead of teaspoon.

I don’t know what did i do wrong.

Thanks for your help Pi

anyone have any idea? I tried to find document in wiki but none describe this problem. It’s like I have to configure somewhere else(other than login page) to let it displays concept in local language.

Have you set the language settings for the user in openmrs?

oh not yet

@angshuonline not sure whether you mean this

but i still get the same result

Thanks Pi

Hi @zacrify, Please follow the below steps to see the concepts in Thai Language in Bahmni

  • Login to OpenMRS -> Admin -> Manage Locales And Themes
  • Enter Thai in Default Locale field and Save.
  • Now Refresh the Medication page in Bahmni and check you can see the teaspoon concept in Thai Language.

As per my understanding Manage Locales And Themes option is different from the defaultLocale option

  • defaultLocale lets you view the openMRS UI in the language of your choice and its specific to user.
  • Manage Locales And Themes option is not specific to user and it lets you see the concepts in Bahmni in the language of your choice.

Hi @binduak

after I change locales and themes to “th” as your suggest. nothing happened the teaspoon unit is still in english not thai.

also I tried steps from https://bahmni.atlassian.net/wiki/display/BAH/Product+Internationalization but many field(in yellow rectangle) seem have no value in Thai. Where should i add those values?

I just found out that registration/locale_en.json in pre-installed v0.89 are not contained all of the keys (there are around 22 keys but I found that in github (https://github.com/Bahmni/openmrs-module-bahmniapps/blob/4b413d7cd8fd37fdd77e2a8a990fa10ffeed8c07/ui/app/i18n/registration/locale_pt_BR.json) contain around 80 keys

so even you copied locale_en.json and change to locale_your_language.json, it won’t cover all of keys and let some button untranslated.

I didn’t try with other modules than registration yet but quite sure they have the same problem.

I’m not sure where can I get the real locale_en.json since the one in github was removed

Please help


Can you share the screenshots of both Admin -> Settings -> Locale page and Admin->Settings page.

I’m not sure you mean this (there is no Settings in Admin)

not sure if it’s related. but after i followed the step from

suddenly I can change to teaspoon to Thai

But there is an error when I enter dashboard (no observation form was revealed)

and when I went to Concept Dictionary in Admin UI there are no search box for concept

but I still can download concept.csv from here

not sure what happening?

Thanks Pi