How to Use the HTML Form Flowsheet Module

Platform Version: 1.11.2 Build 3854fe WAR 2015-04-20 21:42 OpenMRS Version: N/A

Question: I have installed the “HTML Form Entry v2.5” and “htmlformflowsheet v1.2.8” modules.

According to the html form flowsheet wiki I should simply be able to insert:

<htmlformflowsheet formId="39"/>

into my form’s XML and the form with ID 39 should be rendered at this location in this “parent” html form.

To try this out, I created the the following HTML form which uses only concepts in the dictionary distributed with the version of OpenMRS I am using:

vital_sign_entry.html.txt (1.6 KB)

On my system, this form has ID 7. (I determine the form ID by going to Administration -> Forms -> Manage Forms. Then, I move my cursor over the form’s name and read the form ID listed in the URL for the link to the form at the bottom of my browser. I think this is correct. I know I am not supposed to use the HTML form ID, but the base form ID. This is my best guess as where I should find the base form ID)

I then created another form and inserted

<section headerLabel="3. Vitals">
    <htmlformflowsheet formId="7" />
</section>

to try to see if I could get the flowsheet module to work. You can see the form with the embedded form vitals_flowsheet.html.txt (4.4 KB)

However, when I load the HTML form with the embedded form, nothing shows up where the embedded form should be. Any help, or advice on how to get this basic example to work would be greatly appreciated.

Thanks! Trevor

Hi Trevor,

Nothing stands out in what you include below as the obvious problem. Is this something you can reproduce on one of the public demo servers and someone can have a look at live?

Thanks, Mike

Thanks Mike,

I went to http://demo.openmrs.org, logged in, and then went to http://demo.openmrs.org/openmrs/admin/index.htm to access the administration page (the administration link is missing from the landing page). I started to add my forms to see if they would work on this server, but when I checked to see what modules were installed, I saw that the “htmlformflowsheet” module was not available. The ability to upload new modules to the site has been disabled, so I can’t try to reproduce my problem on this public server. Is there another server I could try?

Is the htmlformflowsheet module something that people are still actively using, or is this an old idea that has been replaced by better methods and is no longer under development (i.e. I shouldn’t use it for our site)?

Thanks, Trevor

Hi Trevor,

We still use it at PIH in a number of our implementations, though it is no longer under active development. It gets a very limited amount of support, and I doubt any attempts have been made to ensure it works with latest platform releases, as all of the PIH sites that use it are running OpenMRS 1.9. I don’t know of any better methods that cover the same use case that you could utilize without custom module development, so if it meets your needs it is still worth considering, knowing that support will be very limited.

That being said, if you can find a way to make your error case available on a server somewhere that I can access I’m happy to have a look into it.

Thanks, Mike

Trevor,

Try this: http://devtest02.openmrs.org:8080/openmrs/admin/modules/module.list As for user name and password, the usual suspect. :slight_smile:

1 Like

Thanks Daniel.

I added the HTML Form Flowsheet module and added the two forms I described in my original question above (Vital Sign Entry and Vitals Flowsheet). On this installation, at least something happens. An error is thrown:

HTTP Status 500 - 
type Exception report
message 
description The server encountered an internal error () that prevented it from fulfilling this request.
exception 

Could this be related to HFFS-37? Also, why does it throw the error on this server but not on mine?

Thanks, Trevor

For reference, I am using Apache Tomcat/8.0.21

Seems like a distinct possibility. I just built the latest from source (with the fix from that ticket you referenced), and the flowsheet seems to load correctly from what I can tell. See the preview here: http://devtest02.openmrs.org:8080/openmrs/module/htmlformentry/htmlForm.form?id=12

Mike

1 Like

Thanks Mike & Daniel.

I built the module from the latest source and that fixed the problem for me as well. I also tried running the older, but official release HTML Form Flowsheet v1.2.8 after adding this line to my site’s $TOMCAT_HOME/conf/catalina.properties file

org.apache.el.parser.SKIP_IDENTIFIER_CHECK=true

and that fixed the problem for me as well. This was all addressed in ticket HFFS-37 mentioned above, but when I tried editing my properties file before, it still didn’t seem to work. Perhaps I was confused, as for some reason, when I loaded the form on my computer, it never issued an error. It would only display a blank area where the form should have loaded. After applying the fix above to my config file, the form still displays a blank area, but if I wait a little while, the form will start to load. I was just too impatient, or my computer too slow. Hopefully documenting this will help someone else one day.

One last note, after changing the config file, it seems that you will need to restart Tomcat for the change to take effect.

Thanks again!