How to upload modules on openmrs platform

I just compiled the openmrs-core and ran the war file. When I click the link to access the Add-on manager and install modules, I get a 404. How do I resolve this?

cc: @dkayiwa

Download the reference application modules and paste them into the modules folder.

@dkayiwa, I don’t understand your suggestion

I’m running the .war file after compiling the openmrs-core. There’s no modules folder

Can you paste the log at

The reason I couldn’t see the modules folder was because my computer wasn’t displaying hidden files/folders

Does that mean all is well now?

No, it isn’t. After installing some module dependencies, I get the following error

Error message in Browser

Server Logs

Can you compile and update the serialization module?

Thanks @dkayiwa.

Upgrading the serialization module fixed the errors but immediately I install the emrapi snapshot, I get this:

Error Log

In your emrapi module’s config.xml, remove the resource which has the openmrs versions range of 1.9.* - 2.1.*

That is the one with path “/lib/emrapi-condition-list-${project.parent.version}.jar”

Then compile it and test again.

Removing the resource causes the following error

java.lang.IllegalArgumentException: Found the #comment node under conditionalResources. Only conditionalResource is allowed.

Error Logs

cc @dkayiwa

This means you did not edit it properly. Can you commit your change?


Github Link

Problem was caused by the fact that you tried to comment out instead of removing

@dkayiwa, Thanks. That worked