How do I compile Laboratory module?

Platform Version: OpenMRS 1.9.8

Question: How to compile this module? (generate the omod file )

is there a specific openMRS version required??

I can’t compile it using maven I’ve tried using the simple lab entry module, it works well but I want to test this module out as well.

thanks in advance :slight_smile:

What is the link to the sourecode? I can’t find it on the wiki.

I think its this one

The build fails with

[ERROR] Failed to execute goal on project jsslab-api: Could not resolve dependencies for project org
.openmrs.module:jsslab-api:jar:1.9.0-SNAPSHOT: The following artifacts could not be resolved: org.op,
-SNAPSHOT, org.openmrs.module:webservices.rest19ext-api:jar:1.0-SNAPSHOT, org.openmrs.module:webserv
ices.rest19ext-omod:jar:1.0-SNAPSHOT: Could not find artifact
i:jar:1.1-SNAPSHOT in openmrs-repo (
-> [Help 1]

You could try replacing all reported SNAPSHOT versions in the pom with released versions of modules.

1 Like

Please do try building this to see if it suits your needs.

However as far as I know that module was never completed and was abandoned. JSS hospital, who was to be the target user, now uses the Bahmni distribution of OpenMRS, and specifically OpenELIS for the lab.


Can this be reflected in the repo’s

yes it generates that error, actually I tried to edit the pom files ( deleted the -SNAPSHOT ) but still not able to compile completely, so is this module discontinued?

BTW , thanks a lot for the reply sir :smile:

First of all thanks for the reply , I will try openELIS now , is it possible to connect openELIS with openMRS and dcm4chee?

I want to try openELIS but i cant download the .ova file, it always redirects to the download page, and not downloading the said file .