Hibernate 4 NoSuchMethodError

I am trying to upgrade ugandaemrfingerprint module to work with OpenMRS 2.0.5 but i get this exception. and I think its due to the upgrade of Hibernate. https://pastebin.com/U2x2Puiz. Anyone with a solution @dkayiwa

Do you want this module to also support platform versions before 2.x? If not, then just compile it against the platform 2.x api. Else, you could do something like https://github.com/openmrs/openmrs-module-xforms/commit/5d79f327d27777a40ec755a90433e4dc69067e4a

Thanks @dkayiwa. But I have some issues with null SessionFactory.

What does that mean?

public void setSessionFactory(SessionFactory sessionFactory) {
	this.sessionFactory = sessionFactory;
}    private org.hibernate.Session getCurrentSession() {
	try {
		return sessionFactory.getCurrentSession();
	catch (NoSuchMethodError ex) {
		try {
			Method method = sessionFactory.getClass().getMethod("getCurrentSession", null);
			return (org.hibernate.Session)method.invoke(sessionFactory, null);
		catch (Exception e) {
			throw new RuntimeException("Failed to get the current hibernate session", e);

doesnt set the SessionFactory to any value. leaves it null

I was looking at the example you gave https://github.com/openmrs/openmrs-module-xforms/commit/5d79f327d27777a40ec755a90433e4dc69067e4a

You need to give the full stack trace that you are getting.

@dkayiwa https://pastebin.com/1DBk14Nz

This does not look like the full log in the log file.

Hello @slubwama can you please explain how can i do to make fonctionnal ugandaemrfingerprint ? cc @dkayiwa

@dkayiwa I have solved all issues I had. I was not mapping correctly. so had quite a number of issues. went through them one by one until I nailed it down. Now my Module works fine. thanks for the guidance. I followed examples in Xforms module.

@kamdemclems I will get back to you soon.

@slubwama ok i am waiting thank !

Hello @slubwama can you please can you exxplain how can i do to integrate a fingerprint with ugandaEMR ? It is still urgent for me. Please !

I have have same error can you explain more ?