Help! Stuck at Change Password screen

I am configuring openMRS, and have managed to get stuck at the “Change Password” screen for a test user I created.

I have restarted openmrs, restarted tomcat, I have tried to legitimately change the password, I have clicked the logout button, I have tried to navigate to several different pages in the url, I have pressed the cancel button, I have cleared the browser cache and refreshed, nothing has worked, the page always reloads and shows the change password screen.

Whenever I try to legitimately reset the password, I get an error, “An error occurred but your new password has been saved”. And I can confirm that it updates the password because when I try to change the password again, I must use the new password, not the old one.

I am very stuck at this page, and I dread a user ending up in this position.

Aren’t you taken to home screen after being updated.? Then please post the link of error log pasting in paste bin.

On creating a new user and trying to login first it ask for

I eventually deleted all browser data and that worked. I’m not sure why clearing caching and hard refreshing didn’t work, nor did clearing all data for the past 2 hours…

No, I was never taken to the home screen after being updated.

I think this is telling, WARN - ChangePasswordPageController.post(107) |2019-07-23 15:18:18,287| Failed to set forcePassword user property to false org.openmrs.api.APIAuthenticationException: Privileges required: Get Users

Here is some of the logs, I think the important logs: https://pastebin.com/UmPWDC5K