Hello team! Openmrs keeps giving this error if I try to save clinical forms details. Any help please


(Zainab Ally) #1


(Daniel Kayiwa) #2

Moved to the bahmni category


(Angshuman Sarkar) #3

Can you please mention few other details?

  • What version of Bahmni?
  • How did you install bahmni? Was the installation done with demo data or empty?
  • Did you change the configuration? Especially the groovy script that the error suggests?
  • Did you change any concepts, edited them, changed names etc?
  • When do you get the error? For a specific patient? or for all?

Sharing more context, will help the community to assist you better.

  • Did you get this problem all of a sudden? or did it start happening after certain actions that you did? Can you retrace the steps?

(Zainab Ally) #4

Bahmni version 0.91

Bahmni was already installed, what I have done is to update the system to be just like the other instance we created in the other facility. So I changed the configuration file, bahmniapps, modules and database as well.

And yes I did replace the groovy script with the working one but still problem not solved.

"Did you change any concepts, edited them, changed names etc?" I tried all these but no changes

The error occurs when I try to save data entry for any form and for all patients.


(Angshuman Sarkar) #5

The groovy script is same as in the default-config? If not, will you able to share that - like put up in a gist?