GSoC 2018 - Improved Built-In Reports module

Hi, I’m Menuka Warushavithana [1][2], final-year Computer Science and Engineering student from the University of Moratuwa, Sri Lanka.I wish to contribute to the aforementioned project under GSoC 2018.

I have cloned the repository [3]. However, I’m afraid building the project with npm run build:prod gives out the following error.
ERROR in [copy-webpack-plugin] unable to locate ‘libs’ at ‘openmrs-owa-built-in-reports/libs’

The zip file is created, but it cannot be uploaded to the OWA module. (Says “App is not a zip archive”) @judeniroshan

Any advice is appreciated.



Hi Menuka,

I’m happy to see your interest to work on this project. I checked the repository. Above mentioned issues is causing for webpack bundling. So, for the moment you can clone this repo which I included the libs folder. You can start exploring the module by building this new branch. (you may find a workaround for this build problem in future :slight_smile: )




Hi Jude,
Thanks for looking into the issue. The build is successful now.
But I still get the same error (“App is not a zip archive”) when uploading the app to the OWA module. :slight_smile:
I’ll try to figure out the problem. Again, help is appreciated.


Hi @menuka, You should build the module using npm run build:prod and upload the ZIP file to the OWA module. I hope it will work :slight_smile:

1 Like

Hi @suthagar23 ,
Yeah, it is what I’ve been doing :slight_smile: . The zip file is created successfully. But when uploading the error “App is not a zip archive” is returned.


Hi @judeniroshan, @suthagar23,
I tried uploading the zip file to a fresh copy of the reference application. It works well now. I have checked out [1] as well, and I’m working on understanding the project objectives.



1 Like

Hi @judeniroshan,
I have read the objectives of the project and will be coming up with a draft proposal soon.


1 Like

Hi Mentors,

I am Jeyasumangala from Sri Lanka and currently studying at Sri Lanka Institute of Information Technology.

I would like to work on this project. Your helps and guides will be encouraged me to get more understand about this project. Let me get some introduction and understanding about the project.


1 Like

Hi @sumangala28,

Thanks for your interest to work on this project. :slight_smile:
I believe all necessary information to get started about this project is included here.

Please let me know if anything is missing or not clear to you. It is well known that more interactions with the community will increase the chance of getting selected. Therefore, any doubtful areas that you encounter while working on this project, please don’t hesitate to raise it.

1 Like

Hi Mentors ,

I am Ridmal Madushanaka from Universtiy of Moratuwa, Sri Lanka. I would like to work on this project. Could you please let me know if there any issues or less complex tasks regarding this module which I can contribute.


1 Like

@ridmal If you are looking for introductory issues to work on, you may choose any Reference Application issues. Because this module is delivered with Ref app. So, it would be nice to see that your contributions to Ref App.

We would be happy to see if anyone could report issues that you can see while playing with built-in reports module and work on them.

Thank you so much @judeniroshan for the guides.

I just went through the code repository and followed the npm command to create the package. Then I uploaded the zip file to the Open Web App Manager. After that, I clicked on the Build In Reports to open that one, but I couldn’t get a proper screen(output). I got some script file missing error messages in the browser console.

I have attached a screen shot here. If you can, please guide me to resolve those issues.


Is libs folder exists in your project root?

I couldn’t find anything related to libs folder. I just cloned the repository and followed the commands which was mentioned in the ReadMe.

This original repo has an issue with libraries. (mentioned in the first comment of the talk by @menuka ) So try this repo and see.

Hi Mentors ,

I am Sithija Thewa Hettige , a final year student from University of Moratuwa Studying Computer Science and Engineering. I find this project very interesting and I wish to contribute to it.


I uploaded the file to OpenMRS Open Web Apps module successfully but while running ‘npm run watch’ command i get the following error


appreciate any help to sort this out .

thanks in adavance !!

1 Like

my suggestion (@judeniroshan correct me if I am wrong) This error occurs me when I am deploying this module locally. I think that error is occurred because of the name we used in URL . We actually upload the openmrs-owa-built-in-reports-0.9.4 zip file and in the URL we used openmrs-owa-built-in-reports only. So can you change the openmrs-owa-built-in-reports as openmrs-owa-built-in-reports-0.9.4 and try that again.

when i am locally depoyed Built-In Reports module it shows this kind of UI header. Is it a issue ? ( or occured becuase of the missing of following files in the lib folder)

And try the module on a fresh copy of the Reference application, especially if you’ve been playing around with it :slight_smile:

Hi @ridmal ,

The header bar has messed up because of libs folder is missing. Please verify that your libs folder is present in your server.