Graphs does not display on patient dashboard after upgrade to openmrs242

Hi everyone. I have upgrade from openmrs 2.0.6 to 2.4.2, after upgrade I notice that patient graphs do not display they just show that they are loading.

1 Like

In your OpenMRS log, do you see a message like the following:

java.lang.IllegalStateException: Servlets can not be added to context /openmrs as the context has been initialised

No I can’t find that message.

what exact logs do you have in the openmrs.logs file

The tomcat logs are above from the first post.

I see the same problem on openmrs demo. Have we found the solution for this? https://demo.openmrs.org/openmrs/patientDashboard.form?patientId=323&patientGraphConcept=5089

@jerome24 create a JIRA ticket for it.

You know I am not a developer. I need to register and get started as a developer. For this problem you can help me create a ticket so colleagues can work on it.

It is not loading graphs even on qa server. Have created a ticket here [RA-1982] Diplay Graphs on patient dashboard page after upgrading to platform 2.4.2 - OpenMRS Issues .Feel free to add more comments on the ticket.

More converstions can be found here Graphs do not display. How to customize graphs in OpenMRS - #3 by jmkumbo

@jerome24 you do not have to be a developer to create a ticket.

@sharif i intentionally closed your ticket because i wanted @jerome24 to go through the experience of creating tickets.

Thanks for creating a ticket for it. I did went through that conversation but I could not fix the problem.

Before a developer works on it, a ticket needs to be created.

Ok Daniel let me try to create a ticket, I was having challenges login when I started to create a new issue. So I thought you have to be a developer to create a ticket.

Ohhk great cc @jerome24. :slightly_smiling_face:

@jerome24 i have just updated the documentation with details of what you need to do in order to access our ticketing system, JIRA. After creating the ticket, share its url here.

1 Like

Its great for each community member to know about creating tickets

Dear all, So I was upgrading openmrs from 2.2.1 to 2.4.2 and 2.5.3. Apparently I still get the error of patient graphs not loading I even try it on https://demo.openmrs.org/openmrs/patientDashboard.form?patientId=29&patientGraphConcept=5089 did this have a fix? I am using ubuntu 20.04, java 11, tomcat9 and mysql 5.6. Could an error like this be caused by mysql version?

Did you create the ticket?

I did create a ticket for it. Not sure if I was missing something or what I was supposed to do after creating it [LUI-186] Graph does not display on patient dashboard graphs tab Openmrs 2.4.2 - OpenMRS Issues