Graphs do not display. How to customize graphs in OpenMRS

Do you mean this?

Yes! but in graph section

This link shows the same problem we are facing.

Do you get the same behavior when using other browsers?

Yes, I have tested in chrome and safari both shows the same behavior.

Oh i see! If i wanted to reproduce it locally, do you think you can give me the exact simplest baby steps to do so?

Just login -> and search for any patient -> in the dashboard section choose graph tab -> and enter concept name (e.g. Weight) in the section Add New Graph:Find Concept(s).

I have confirmed that it is a bug. Can you create a ticket for it under the legacyui module JIRA project?

Yes, I’ll do.

I have tried to install legacy UI module in the demo of openmrs I have installed in my pc and graph was produced, but installation in the ubuntu server graphs does not work.

What version of the legacyui module do you have?

I have cloned a github repository for this module and I built the module and then I used legacyui-1.4.0-SNAPSHOT.omod

Can you refresh or clear your browser cache?

I have refreshed and I have cleared browser cache, also I have tried in different browser but it does not workout.

Are you able to reproduce the problem on If you access this link it will throw an error

An error has occurred! The following error happened somewhere on this page: javax.servlet.jsp.JspException: org.hibernate.exception.GenericJDBCException: could not execute batch

Graph is working in this link.

The difference is & and # sign between this two link,

can you send me your omod file in order to try it?.

I have just released version 1.4.0 of the legacyui module. Can you try it out?

1 Like

Graphs didn’t appear.