Getting HTTP Status 404 when trying to access apiDocs.htm

I created a new resource called ConditionResource2_2 and I wanted to test whether it shows up in the API documentation. However, when I build the rest module and copy the omod file generated to the modules directory in the reference directory, I always get this error: HTTP Status 404 - /openmrs/module/webservices/rest/apiDocs.htm. I have also tried using the OpenMRS SDK to run an instance of the platform but I still get the same result.

This is the guide I have been using.

I also have this warning: WARN - OpenmrsUtil.getRuntimePropertiesFilePathName(2085) |2018-03-19 12:10:20,987| Unable to find a runtime properties file at /Users/arthur/dev/openmrs/

Could someone kindly point me in the right direction.

Without giving the entire log, it would require a magician to figure out what is going on. :wink:

Sorry about that. Here are the logs

Which openmrs platform or core version are you running?

The Platform version I set up was 2.1.2

Use the latest snapshot version

@dkayiwa, I tried using the latest snapshot version but I’m still getting the same error.

Exact platform version are you using?

Version 2.2.0-SNAPSHOT

Can i look at the current log?


What shows up in your browser?


What happens when you access this? localhost:8080/openmrs

That works fine. I get this:

Can drop the legacyui module into the modules folder and restart openmrs?

It now renders the page successfully. However, I only have 2 resources showing and a bunch of errors at the top of the page.

Here are the errors:

The bottom of that page should have lots more resources.

Don’t know what the issue was. I restarted the server and it loaded more. :smile:

Thank you. My Condition resource is now visible

Awesome! Yes restarting should always be a good arsenal in your toolbox. :smile: