Getting an error on running maven clean install on openmrs-distro-referenceapplication

I am following the steps here to set up my environment for QA. I am stuck on step 1 after running maven clean install.

Here is my error

@k.joseph , @kdaud

Make sure to fetch all the latest changes and ensure to run mvn clean install against qa branch

I actually deleted the old clone and cloned again. after I ran the git fetch --all,

git checkout qa and then the maven clean install.

Is there any step I missed out? @kdaud

The right command is mvn clean install

sure that is what I ran mvn clean install. Check the logs.

Clone from the upstream repo at GitHub - openmrs/openmrs-distro-referenceapplication and build again

@kdaud I cloned from the upstream repo . The one on the wiki page was giving me permission related errors so I just went ahead and cloned from the upstream repo.

Did you look through the error logs, look at these lines

[ERROR] Failed to execute goal on project referenceapplication-package: Could not resolve dependencies for project org.openmrs.distro:referenceapplication-package:jar:2.12.0-SNAPSHOT: The following artifacts could not be resolved: org.openmrs.api:openmrs-api:jar:2.4.0, org.openmrs.api:openmrs-api:jar:tests:2.4.0: Could not transfer artifact org.openmrs.api:openmrs-api:jar:2.4.0 from/to openmrs-repo ( Connection reset → [Help 1]

What does mvn -v returns

@irenyak1 looking at your logs, it looks like you need a good connection(internet),building from my side right now ,going to give you feed back

mvn -v returns

Apache Maven 3.6.0 Maven home: /usr/share/maven Java version: 1.8.0_282, vendor: Private Build, runtime: /usr/lib/jvm/java-8-openjdk-amd64/jre Default locale: en_GB, platform encoding: UTF-8 OS name: “linux”, version: “5.4.0-65-generic”, arch: “amd64”, family: “unix”

Is it the same error building this GitHub - openmrs/openmrs-contrib-qaframework

I thought about that too so I have been trying to build at different times of the day to catch good connection but it still brings errors

let me confirm my logs

This is the error I get for this. I am afraid it could be my network.

hi @k.joseph i notice running openmrs-distro-reference application using the upstream ie GitHub - openmrs/openmrs-distro-referenceapplication on the qa branch breaks with the following logs Microsoft Windows [Version 10.0.19041.804](c) 2020 Microsoft Corporation. All - ie same logs after running two times

@k.joseph same logs even after forking the repo and building with the latest changes

@herbert24 you need to make non of your local changes are blocking you, ensure u basically have the qa branch checked out with out any changes and comiple again, remember to be in ui-tests folder

@irenyak1 is your maven setup right. if so try hiding behind a vpn!

1 Like

@irenyak1 When you are cloning try to check whether your URL is and then follow all the steps

@k.joseph let me do so.

@gracebish I was very careful on that. Thanks