Getting an error on running maven clean install on openmrs-contrib-qaframework

On step 3 of the QAFramework Technical documentation(Cucumber-Selenium&Cypress Set up)

I get this error when I run mvn clean install

Could you look through my error @k.joseph , @kdaud

Ensure you have build the right branch of uitestframework and referenceapplication module as indicated in step 1 and 2. On step 2 ensure to pull the latest changes on qa branch of the distro. Then also pull the latest changes on qaframework module and build again. I recommend always to share the full log error

@kdaud which branch do I have to switch to? I am working with the master branch and it is the only one I see present.

After git fetch --all , I re-run mvn clean install and this is the error I’m getting.

When building the qaframework module its the master. Could you have a response to my comment i made above

@kdaud I did all the above. The uitestframework and referenceapplication module compiled successfully.

According to error message, you pulled the latest changes on qaframework. This means that you compiled the distro before some resources were refactored to this module and now when you try building the qaframework module, the compiler is not able to locate these resources (AllergyPage) from the jar that was generated by the distro before the new changes were added. Pull the latest changes of distro against qa branch and build it first then building qaframework module should pass

1 Like

Before building the distro delete the three old generated jar file in the folder located at /openmrs-distro-referenceapplication/package/target.

1 Like

Any progress

I see only two jar files in that directory, the other is

Remove all including that with .zip extension. And also remove the two jar files that are present in /openmrs-distro-referenceapplication/ui-tests/target. Then share the outcome after rebuilding the module

@kdaud when you say remove all, do you mean the two jars and the or you mean I empty the whole target directory? It has many other directories in it. I need some clarification.

I meant this tag

1 Like

I have deleted the jar files, updated the qa branch in distro and run mvn clean install. The distro successfully built. but the qaframework is still failing irynah@irynah-Vostro-3560:/media/irynah/DATA/0NEW-108G/0PROJECTS/OpenMRS-project -

Which command did you apply to update your qa branch in distro

git fetch --all. Or could I have used a different command? Let me know.

While standing on the respective branch, use git pull --rebase upstream qa

1 Like

Thanks @kdaud . it has worked after updating distro and building it.

@k.joseph and @kdaud this line in the qaframework documentation does not seem to match what is in the qaframework that I have.

Chrome: src/main/resources/chromedriver/<linux/mac>/chromedriver or src/main/resources/chromedriver/windows/chromedriver.exe

Th qaframework on my side shows this

Chrome: src/test/resources/chromedriver/<linux/mac>/chromedriver or src/test/resources/chromedriver/windows/chromedriver.exe could it be that we need to edit that part of the documentation, or there’s something I am missing?

please update appropriately and thanks @irenyak1 for catching this

Welcome @k.joseph . I did that and am running tests now.

1 Like

When I run mvn clean test on the openmrs-contrib-qaframework, I get a build failure