Further Improvements to Addons( WEBAPP)

(jagadeesh dharmarajula ) #1

Hi @darius ,@reubenv I am jagadeesh. I have been working on the implementation of Bahmni on our local server. I’m very interested in this project and would like to take it up, but I’m a little unsure of where I should be proceeding from here, and Please give me information about the next steps .

Thanking you!

(Darius Jazayeri) #2

Hi @saijagadeesh,

My suggestion for this project is that you should take a look at the actual website https://addons.openmrs.org/ and think about some improvements that could be made.

Some possible ideas (not necessarily all good ones):

  • fix the webpack setup so that end users see new versions of the webapp without having to click shift-refresh
  • improve the searching algorithm
  • introduce an advanced search syntax, like “name:report label:deprecated”
  • display comments that people make about addons in bintray within the addons UI
  • display ratings from bintray within the addons UI
  • simplified UX flow to help someone add their own addon to the index
  • automate the process of adding a list of refapp modules when a new version of the refapp is released
1 Like
(jagadeesh dharmarajula ) #3

OHK SIR Thank you

(jagadeesh dharmarajula ) #4

Hello @reubenv ,@darius .

sir,

I installed the Modules but it is not showing the modules as per the documentation. Can you please help me in resolving the issue .

This is the link below for documentation. https://wiki.openmrs.org/display/projects/How+to+install+Modulus+and+Modulus+UI#HowtoinstallModulusandModulusUI-Key_Set-Up

Thaking you sir

(Daniel Kayiwa) #5

What happens when you click the details link?

(jagadeesh dharmarajula ) #6

Hello sir,

When we click on this link It shows documentation of the commands to install the modules.

Thanking you

(Reuben Varghese) #7

Hey @saijagadeesh , I guess you meant to install OpenMRS AddOns . What you’ve installed is OpenMRS modulus which has now been replaced by AddOns. That’s probably why the modules don’t show up. The modulus APIs probably don’t work anymore. You probably want to install this project.

(jagadeesh dharmarajula ) #8

Thanks for reply sir.

(jagadeesh dharmarajula ) #9

Hello @reubenv I am not understanding the docker commands in the documentation that you mentioned in above reply. So please help me in resolving this issue.

(Darius Jazayeri) #10

@saijagadeesh, note that the people you are asking for help are volunteers for OpenMRS. We are happy to help, but…

Please ask a specific question and point to the specific steps you tried, and what didn’t work (e.g. what was the error output of a command).

(jagadeesh dharmarajula ) #11

@darius Sorry sir, From now I will be more specific about the problem that I mention. thanking you sir

(jagadeesh dharmarajula ) #12

hello @darius @reubenv I am getting error while navigating through the local host. The page is showing nothing! http://localhost:8080/

please help me resolving the issue.

(Darius Jazayeri) #13

@saijagadeesh what instructions did you follow to get to this point? what was the output?

(jagadeesh dharmarajula ) #14

Hello @darius Good Morning sir, This is the link which I followed sir

In building and running the server, after executing this command java -jar target/addonindex-*.jar I should navigate to local host http://localhost:8080/. But it’s showing that page not found error.

Thanking you

(Darius Jazayeri) #15

@saijagadeesh, please google around for “how to ask good technical questions”.

Did you run all the steps up until that point (e.g. Building the Web UI, and ElasticSearch)?

What was the output when you ran the java -jar command?

(jagadeesh dharmarajula ) #16

Yes sir I have executed all the commands in Building the web UI and elastic search.

The error occurred in Starting ApplicationContext sir.

(Reuben Varghese) #17

Hi @saijagadeesh , as per the logs, it looks like elasticsearch isn’t running.

You might also want to follow the discussion here. Since you mention that you’re unable to follow the docker commands, I would suggest that you try to install elasticsearch without docker. From your screenshots, I am guessing that you’re using a flavor of linux. Try to look for tutorials on installing elasticsearch similar to this based on the linux distro you use.

(jagadeesh dharmarajula ) #19

I re-installed the the addons project but again the same error is occurring, Error in starting application. elastic search is also working fine.