From "grunt test failure" to "in search of audit log omod"

1/ While setting up bahmni development environment as mentioned here it failed on grunt test throwing error -

Connected on socket TrCl876ZaBqpXxUWAAAA with id 83326953 Firefox 55.0.0 (Windows 10 0.0.0) conceptDbService tests should update children of concept if there are setmembers FAILED Error: Timeout - Async callback was not invoked within timeout specified by jasmine.DEFAULT_TIMEOUT_INTERVAL. in C:/Projects/Bahmni/AWS/Sandbox/openmrs-module-bahmniapps-master/ui/node_modules/karma-jasmine/lib/jasmine.js (line 281)

2/ Did it second time only to get coverage as follows: (good / bad?) Statements : 70.49% ( 12189/17292 ) Branches : 59.73% ( 4579/7666 ) Functions : 63.14% ( 3278/5192 ) Lines : 70.53% ( 12153/17232 )

3/ Still tried bahmni login. After successful login every page throws error “Information Does not exist”

4/ Please note the above error is seen in both options suggested here Option 1 sudo ln -s /bahmni/openmrs-module-bahmniapps/ui/dist/ /var/www/bahmniapps

Option 2 ln -s /bahmni/openmrs-module-bahmniapps/ui/app /var/www/bahmniapps

The Chrome debugger shows the error as Failed to load resource: the server responded with a status of 404 (Not Found) /openmrs/ws/rest/v1/auditlog

Based on this thread found that auditlog related omod is missing from /opt/openmrs/modules.

5/ But then why does the error disappear if /var/bahmni/www is pointed to the original folder installed in vagrant box which is /opt/bahmni-web/etc/bahmniapps/?

  1. As a temporary fix turned off the audit log as mentioned here but 2 questions remain -

A. In terms of Audit log what’s the difference in the one that is built locally as mentioned here and the one that comes with Bahmni Vagrant box?

B. And where to get audit log related omod so that audit log need not be turned off. Any suggestions?

Host OS: Windows VBox: Bahmni version 0.89 atomfeed-console.noarch 1.0-18 @bahmni bahmni-emr.noarch 0.89-316 @bahmni bahmni-erp.noarch 0.89-43 @bahmni bahmni-erp-connect.noarch 0.89-43 @bahmni bahmni-implementer-interface.noarch 0.89-93 @bahmni bahmni-installer.noarch 0.89-167 @bintray–bahmni-rpm bahmni-lab.noarch 0.89-64 @bahmni bahmni-lab-connect.noarch 0.89-316 @bahmni bahmni-openmrs.noarch 0.89-83 @bahmni bahmni-reports.noarch 0.89-59 @bahmni bahmni-web.noarch 0.89-316 @bahmni epel-release.noarch 6-8 @bintray–bahmni-rpm python-gdata.noarch 2.0.11-1.el6 @bahmni

Please note all services are running.

Hi Nawaz,

Assuming you were able to run the tests successfully, so not answering to your first question. Coming to the coverage, it has been bad since long time and we have been trying to make it better everyday. If your are willing to write some tests to increase the coverage, you are always welcome.

To answer your 3rd,4th and 5th question, you have 0.89 version of bahmni installed on your vagrant box and I am assuming that you are trying to symlink the master branch of bahmniapps. This is the reason you are getting an error. Can you try to symlink the release-0.89 branch of bahmniapps instead of master.

This should resolve all your issues. Let me know if you still face any issues.

Thank you for the solution but I have one more question as I moved ahead.

Surely I will try few.

Yes, it resolved the error “Information does not exist” due to audit log related problem.

I could compile bahmni-code as mentioned here

BUT when I tried openerp-atomfeed-service, I get the error related to shouldEscapeHindiCharacters (getting reported in file \Projects\Bahmni\openerp-atomfeed-service\openerp-client\target\surefire-reports\org.bahmni.openerp.web.request.builder.RequestBuilderTest.txt) stating “expected and returned strings do not match”. I have also listed this error here

Is this again due to version mismatch (but I cloned what is related to 0.89) OR the test related issue?

May I request you to look into this?

The environment is same as mentioned earlier in this thread.

I could proceed with skiptests = true but is it good/bad?

For debug the file /opt/bahmni-erp-connect/etc/bahmni-erp-connect.conf gives debug port as 8002. So changing the forward port in vagrantfile, restart vbox and connecting remote debugger on 8002 will give an opportunity to debug openerp-atomfeed-service (bahmni-erp-connect)