File system space - Bahmni not working

The above error gives this message from openmrs.log file. Once again, please assist if you have any clue to this issue.

WARN - DispatcherServlet.noHandlerFound(1120) |2018-08-08 23:43:00,037| No mapping found for HTTP request with URI [/openmrs/ws/rest/v1/session] in DispatcherServlet with name ‘openmrs’

Dear Monasela I haven’t gotten you well regarding your response to the issue am facing. Could you mind if you clarify more. Thanks

I am assuming that you have 0.89 and thats the version you want to retain.

  • If you don’t have pgbackrest or can’t get that to work, then you can manually take database dumps (mysql and postgres) and restore them . Keep in mind you also have to restore the configs, and any files (patient document, pics etc) uploaded in representative directories. Use “mysqldump” for openmrs (with “–routines” options), use “pg_dump” for postgres dbs (clinlims and openerp databases).
  • Install Bahmni on another machine. Before you run the bahmni install command, you can keep your individual database files at specific locations, check here (especially step 3) and bahmni installer will pick that up during install.

I am afraid I don’t quite understand. This seems quite off topic. If you want to talk about ‘business continuity process’ of a hospital (assuming thats what you meant by ‘hospital is down’), then its an interesting topic and not to taken lightly, and you may start a different thread altogether.

(on a side note, if the hospital is really down - I wouldn’t really care about software/information systems, as the first priority is how to keep basic operations going, and things move purely by human intent and ingenuity - I know there are SOPs for such dire scenarios)

Thanks you Sarkar, I have now done bahmni install, but finally Am still getting the same error. Really stack, can’t understand what is happening. Any further tips please!

This is the typical error I always get after in /var/log/openmrs/openmrs.log

09-08-2018 20:12:00 [WARN ] PageNotFound - No mapping found for HTTP request with URI [/openmrs/ws/rest/v1/session] in DispatcherServlet with name ‘openmrs’

Dear Gift Mfugale, I meant contingency planning of how the staff of the healthcare establishment will do without the software while waiting for the fixing of the technical problem that it has. I think the technical technological staff may need to think about some solutions beyond the use or no use of the software, especially if the problems of (the software is down for hours and the staff are handling their work without the software untill it is fixed).

As for the reference where i thought about the two ideas, they are adapted from the attached book. I think if we can (think tank) it, this can be great :slight_smile: Regards, Mona

Hmm, that can happen if OpenMRS web container didn’t start properly or the relevant webservices module was not installed.

  1. Can you paste the list of modules in “/opt/openmrs/modules”? Also.
  2. Clear the logs from /var/log/openmrs/
  3. Do “service openmrs restart”
  4. Keep watching the log “tail -200f /var/log/openmrs/openmrs.log”
  • there might be other failures that are the causes, and the log is just the end state.

Thanks, Will try it again, However I have done this several times and the errors stand the same

09-08-2018 20:12:00 [WARN ] PageNotFound - No mapping found for HTTP request with URI [/openmrs/ws/rest/v1/session] in DispatcherServlet with name ‘openmrs’

@angshuonline me and arjun have tried helping Gift over call. It was very weird.

  1. /opt/openmrs/modules folder has all the modules required
  2. Openmrs starts but the ui says there is no ui modules even though it is there.
  3. the below exception is usually caused by missing webservices rest. As i already mentioned, modules are already place. We have verifies /home/bahmni/.OpenMRS/modules aswell.

No mapping found for HTTP request with URI [/openmrs/ws/rest/v1/session] in DispatcherServlet with name ‘openmrs’

  1. Verifies permissions on modules.
  2. Ensures that the application_data_directory is /opt/openmrs.
  3. Reinstalled, just bahmni-emr, bahmni-openmrs rpms => still issue persists
  4. Reinstalled, entire bahmni-installer and ran bahmni install command => still issue persists

I am out of ideas to check this. Any help would be appreciated here. @binduak @shruthipitta @bharatak @arjun @dkayiwa @mksd @krishnanspace @darius @sumanmaity112 @shashikanth

Can you try to clear the browser cache? Or put your cursor in the browser address bar and press CTRL + SHIFT + R

Or simply try a different browser?

Hi @dkayiwa, This didn’t solve. Still the problem persists

Can you paste the server log at

Thank you for responding, here is the openmrs log

This does not look like the full server log.

Dear @Daniel,

To clarify more on the problem, have a look at the screenshots . Basically I have installed Bahmni distro of openmrs and it has been running just fine for one year now. Haphazardly it started this commotion.

a. When I first open it i get this

b. When I open openmrs, I get this


a. We have tried reinstalling emr and opemrs

b. Reinstalled bahmni-installer

c. checked Modules in openmrs, and found nothing is wrong

d. Reinstalled bahmni with both bahmni -local install and bahmni install

Thank you!

Ok. May be am not picking it the right way, I take it here /var/log/openmrs/openmrs.log.

Is that all that the log file has?

I hope this is fully

Well, in the hope that REST WS is actually running (which is not clear at this point), could you try this:

curl -u superman:Admin123 --location ",started,version)"

And share the JSON output on with us?

As you can see I’m also assuming that you are still using superman / Admin123 as OpenMRS credentials. Obviously if that is not the case, use the appropriate credentials.