Failing to install Standalone Ref Application [SOLVED]

Hello friends, Have encountered an exception while installing Standalone Reference Application 2.9.0. Have recognized the problem may be concerned with database configuration in but could not understand what to do exactly. Here is a pastebin link

@kdaud try re-extracting again and run the standalone afresh

@gcliff Have tried it several times but the same exception is thrown. Even when I tried standalone ref application 2.2.0, it throws similar error

Do u have the mysql instance running on your pc when u start your standalone?

@kdaud what is the name of your database?

which java are you running apparently?

@kdaud There might be two things that could cause the issue you’re facing. 1. Your is missing certain vital parameters that establish a connection to the db. 2. Your Java version installed, i will suggest you paste your via and as well share your java version output.


Am sorry for reply delay. Had been fixed up with College Exams.
cc: @gcliff, @herbert24, @jwnasambu, @ggomez

@herbert24, java -version gives
java version “1.8.0_221” Java™ SE Runtime Environment (build 1.8.0_221-b11) Java HotSpot™ 64-Bit Server VM (build 25.221-b11, mixed mode)
While javac -version gives
javac 1.8.0_221

@jwnasambu, I have openmrs though am thinking this database is the one created when installing openmrs sdk

@gcliff, I have no mysql instance running apparently during standalone installation.

@ggomez, Here is the pastebin link and the Java version link is here

If you don’t mind try using the db username as openmrs and password as test then share the output.

@jwnasambu As per configuration file, the db connection.username=openmrs and connection.password=test.Here is the link to the file output

Is your MySQL instance truly running on port 3316? The default is 3306.

@sjmckee Mysql instance is not running

I thought of changing the port number of Mysql but it didn’t work out.
cc: @gcliff @jwnasambu @sjmckee @ggomez @herbert24 @samuel34 @sharif @ruhanga @rushikesh @reubenv

@kdaud may be lets try re-downloading standalone 2.9.0 and if it generates the same error again then u can also try running standalone 2.8.0

Let me do it and see

@gcliff On the download page, I can only see two version 2.9.0 and 2.2.0. The standalone 2.8.0 am unable to see it.