Failed to push my changes on github

I create a new repository in my local and complete the changes. After that, I opened my Github desktop to push the changes to my GitHub repo. As soon as I click the publish button it gave me this error ‘https://github.com/openmrs/openmrs-core.git/’: The requested URL returned error: 403" How can I solve this issue?

hello @lufafa it seems you are pushing to upstream core repo and not origin,am thinking that’s why you are getting that error because you can only push to your origin and and then create a pull request to be reviewed and merged into the upstream core repo…

KIndly fork from upstream and then clone from origin to your local… Thanks

1 Like

@lufafa

Fork it fist push the changes to the fork :slightly_smiling_face:

1 Like

@lufafa push to your fork not to openmrs,so first fork openmrs-core as recomended by @ayesh

2 Likes

you may want to checkout this…https://www.youtube.com/watch?v=SbbDvMVgRWo&t=321s

1 Like

@ayesh i have followed the procedure but i have the same problem.

@gcliff i did this and still get the same results

You have to change the remote head to you’re fork ohterwise u cant push

When you do git remote -v within your project/module on command line, what is the output? Please share that

This is the output git remote -v
origin https://github.com/openmrs/openmrs-core.git (fetch)
origin https://github.com/openmrs/openmrs-core.git (push). What could be the way forward?.

Hi @lufafa

Please follow this guide by git hub

https://help.github.com/en/articles/configuring-a-remote-for-a-fork

1 Like

This means you are pushing to a remote that you don’t have access. Please configure it to your remote(your folk make it origin) and later if you want to contribute that to openmrs core(which should be you upstream), create a PR for that. NOT all people have the POWERS to commit to openmrs core bro! follow @ayesh link

1 Like

@lufafa Fork the repo, clone it into your local machine,Make sure your upstream is up to date, then create a new branch. You can only push codes to your origin but creating a pull request from the master branch must be up to date.

1 Like

hello @lufafa where u able to resolve this issue ?

if not,can we meet at irc and we get this done!!

hello @gcliff, I’m working on it. in good time i’ll be through and update you all my friends who have helped me

1 Like

cool man :+1:

hey @ayesh, @gcliff @ningosi, @herbert24 @sharif @reagan thanks for your help. it worked well. many thanks

thats cool @lufafa

can u please share here how you resolved it so that any other dev who gets the same problem might refer to this thread for the solution that u shared

Thanks :+1:

@gcliff well i tried all the options and got a fail at the end. so i deleted the project and started all over. with the guidelines as advised in the link. thought that was easier way to go.

1 Like