Failed to create a server with openmrs sdk

OpenMRS SDK version : 3.12.4

Following procedures here, I have tried to create an openmrs instance server of Reference Application 2.8 using the SDK. But the built has failed due a NullPointerException here is the full log. Your help is needed here coz am currently blocked :roll_eyes:

CC @dkayiwa ,@ssmusoke , @darius

have you been successful before following the exact steps. it happened to me sometime but i kept redoing it following teh same steps until i suceeded.

Thanks for the response @deb But I have tried it out a couple of times and got the same error.

@samuel34 I am assuming that your root account has no password. This tends to have a number of issues - I usually recommend adding a password to root or creating a new account with a username and password

@ssmusoke , my root account has a password. Whats confusing it doesn’t reach the option of “enter password”. In other words when I enter the mysql user name, it just fails the build.

Could you please try running “mvn openmrs-sdk:setup -e” so we can see the full stack trace?

Try with a different user account…

Hi @raff Here is the full stack trace

Hi Samuel if you have already SUCCESSFULLY installed the SDK then try running this command mvn openmrs-sdk:setup-sdk -U before running mvn openmrs-sdk:run . It worked for me, I hope it works for you too.



Thanks! As a workaround try providing the password as

mvn openmrs-sdk:setup -DdbPassword=“REPLACE_WITH_YOUR_PASSWORD”

What’s your OS?

Am using windows @raff

Oooohh @irenyak1 I have already updated my Openmrs-SDK (mvn openmrs-sdk: setup-sdk -U). But its failing

Sorry, you may need to keenly check your environmental variables, to see if everything is fine.

Thank you @raff . specifying the password parameter resolved the problem. Am now good. :grinning:

1 Like

For more Info…

on windows OS…

When i try to set up a server using git bash , SDK fails to connect to the database , it only works when using the Windows command Prompt

cc @raff @dkayiwa

I think , the reason for the above ,am running Mysql for windows yet Git bash is a unix enviroment