failed openMRS setup

hello team, hope all is well. I am finding a challenge to set up my openMRS. I need help with figuring this out.what do you make of this https://pastebin.com/FcbwYQVb @dkayiwa @jwnasambu
thanks in advance

@spkabugo1 do you have a strong Internet Connection ? Also did you clean the folder before doing a fresh clone ? Notice this Error fatal: destination path 'openmrs-core' already exists and is not an empty directory.

Yes i believe so,unless otherwise. Are you suggesting it could be the cause?

Take note of these two things

  1. Stable Internet Connection

  2. Clone after deleting previous installations.

please guide me on the second part(

Before you download any new dependencies always delete previous installations ,as they could be the cause of the errors.

1 Like

I see this

The forked VM terminated without properly saying goodbye. VM crash or System.exit called?

in your error log . I hope this link could be of some help :slight_smile:

1 Like

I need help with this error message. Whenever I run the basicexample, it pops up at the end

[ERROR] Failed to execute goal org.openmrs.maven.plugins:openmrs-sdk-maven-plugin:3.13.2:run (default-cli) on project basicexample: Execution default-cli of goal org.openmrs.maven.plugins:openmrs-sdk-maven-plugin:3.13.2:run failed: Failed running Tomcat -> [Help 1]

Could this be caused by the maven plugins or something else??? I am really stack.Any help will be greatly appreciated

I don’t see this error in the log you posted?

@spkabugo1 error log ??

thats the error

Hello, @dkayiwa @jwnasambu @haripriya @haripriya I run maven plugin updates in the openmrs-core directory. Does this mean I am now good to go

https://pastebin.com/a0Cs1z4n

thanks for the help

1 Like

I like the zeal you have . Has it sorted out your issue? try running a fresh just to confirm the same error doesn’t happen again.

1 Like

am a liitle confused here,are you able to run openmrs now?? if not,have you checked this https://wiki.openmrs.org/display/docs/OpenMRS+SDK

@herbert24, I have over 5 tabs open talking about openmrs +SDK. I am having a problem with my connection. Probably that is why am not making full headway. let me first fix my connection issues. otherwise thanks for the assistance

1 Like

Indeed am stack, I need help. I have tried to update maven but failed with this https://pastebin.com/a3Ve4SPb.i am trying my best to go by the guidelines on https://wiki.openmrs.org/display/docs/OpenMRS+SDK, but I am just rotating in a circle…Please come to my rescue:hot_face:

1 Like

Go to Start->Control Panel->System->Advanced(tab)->Environment Variables->System

Variables->New:
Variable name: _JAVA_OPTIONS   
Variable value: -Xmx512M
3 Likes

if you happen to get some time you can also get here https://webchat.freenode.net/and ping me so that you can have real time feed back after every step

1 Like

I have made the adjustments @dkayiwa. what should I now do next?

hello @herbert24, I have tried to reach you via the shared link and I am getting a 404 Not Found error message. what could be the cause

1 Like