Error with Manage Concept Dictionary

Hello all,

I am using Ref App 2.6. Under Configure Metadata>Concepts I get the following error

When I try to access the concept dictionary, and search for any concepts (such as rash) the screen freezes on the following screen :

The only way I can access the concept dictionary is to sign in using localhost. I cannot access it over the internet.

Any suggestions to resolve this issue.

Thanks very much

Any help is much appreciated

Can you paste the contents of the server logs at

Thanks @dkayiwa

Here you go

Thanks again

I appreciate any help or guidance in this regards.

Thanks very much

Did you find anything in the logs @dkayiwa

Is this the url that you are trying to access?

Yes… Thats correct @dkayiwa

Are you able to access the same url from localhost?

Yes @dkayiwa I use windows server for testing and it works fine from local host

Is that the only page that you fail to access remotely?

Yes… The application works fine otherwise.

However, If I try to access this page from here :

I can open the page, but the page freeze when I try to search for concepts. I cannot get any result back.

If I login from local host, it work perfect!

Did you figure this out?

Nope. I never managed to make it work. I tried several times to reinstall OpenMRS. Never worked :frowning:

Do you see any errors on the browser’s JavaScript log?