Error while installing reference app

Hi Im new to OpenMRS. Im able to install OpenMRS platform 2.3. But when I upload all the modules this error occurs. Any help please. Thanks in advance.

The following error occurred at startup: https://pastebin.com/QY6mqenw

Can you edit your post by replacing the error log with a url to where you posted the log at pastebin.com?

Sorry for the late reply. Here is the link: https://pastebin.com/QY6mqenw

@chrisrokz as you await response from @dkayiwa share to your dev environment specs ie java version

@gcliff Im using Java 8. If I remove emrapi-1.27.0.omod file from modules then OpenMRS works well. I dont know why this particular module is creating problem.

can you building the emrapi module and use the latest version in your modules folder https://github.com/openmrs/openmrs-module-emrapi

@gcliff Im unware how to build .omod module using the link.

@chrisrokz Do you see Internal server error 500 written anywhere?

@sidvaish97 No I dont see Internal server error 500.

U clone fork the module module to your github and then clone it,this video will help on how https://www.youtube.com/watch?v=SbbDvMVgRWo&feature=emb_title

@chrisrokz I guess I was facing a similar issue. If you are using a Linux machine try running these commands

sudo apt-get install libxrender1:i386

sudo apt-get install libxi6:i386

sudo apt-get install libxtst6:i386

@gcliff Thanks for the video. I’ll move as in instruction.

1 Like

@sidvaish97 I tried those commands but no luck.

Replace all your modules with the ones zipped as referenceapplication-addons-snapshot at https://ci.openmrs.org/browse/REFAPP-OMODDISTRO-9582/artifact

@dkayiwa I did as instructed but occured new error https://pastebin.com/7gpNN4Yb

Just restart OpenMRS.

1 Like

@dkayiwa It worked. Thanks alot.