Error while doing OpenMRS SDK installation

Application Name: Platform

Question: I am a new member to the OpenMRS community and was trying to go through the guide for new developers for some basic guidance. I was following the OpenMRS SDK installation guide ( I reached the stage to deploy n run the basic example module. But everytime I run the " mvn clean install openmrs-sdk:run", get an error saying “Failed running Tomcat”. I get the API and OMOD executed successfully. I tried a few things, checked if Tomcat was installed and running, but nothing that I could think of or find helped me out. What do I do?

@sar99 sorry about it! kindly share the entire error log using pastebin.

1 Like

here’s the link for the log when I run the command.

Should I also post a log with the debug mode?

Which maven version are you using?

In the log, you have this message The JDK 11.0.6 is not compatible with OpenMRS Platform 2.1.4. Please use JDK 1.8 to run this server.

So just switch to Java 8

Oh ya…Silly mistake… Thanks a lot though!