"Error while deserializing address layout template" while creating new patient in Legacy UI

Hello everyone,

Im currently learning OpenMRS and trying to get to know the application. I installed OpenMRS core v2.4 and Legacy UI v1.7 through git on Eclipse on Windows, and run webapp with jetty.

When I tried to add new patient, “Error while deserializing address layout template” is shown in the “Address” field. If I proceed I’ll get exception saying “address cannot be null”.

I tried clearing cache and reinstalling many times, using LegacyUI v1.6 from the web but didnt work because I think it’s compatible with this version of OpenMRS Core. I also tried 2 different windows machine, and installed serialization.xstream.master but the problem persists. My friend who installed openmrs on ubuntu has his address field showing just fine.

It is much appreciated if someone can guide me through this. Thanks in advance.

Can you share the server side log via pastebin.com?

Hi Daniel,

Here’s the log since from the point the server started: https://pastebin.com/yGfftn3X

For this I signed on => Find/Create Patient => Create Patient (fields filled) => Save (Fields filled, Address form not showing) => HTTP ERROR 500

Here’s the log starting at the initial build: https://pastebin.com/XRr6N5CQ

Thank you.

Using pastebin.com, share the contents of your global property (setting) named layout.address.format