Error while creating Visits using REST

I got this error initially when I was creating a patient, somehow it worked after sometime. Then I got the same error while creating encounter/obs but that is also working now. Now when I was creating a visit I am getting the same error BaseDelegatingResource:740.

URL: http://localhost:8083/openmrs-standalone/ws/rest/v1/visit METHOD: POST USERNAME: admin

[HEADERS] username: admin password: Admin123


[CONTENT] { “patient”:“c342807d-fc65-4de1-983e-424c4add487d”, “visitType”:“7b0f5697-27e3-40c4-8bae-f4049abfb4ed”, “startDatetime”:“2017-07-27T15:03:40.000+0530”, “location”:“bf38803c-b24c-4d54-bd8d-15fe17a79d0d” }

Error is here =

Ensure that you have a patient with that uuid

Yes There is a patient with that uuid There is a visitType with that uuid There is a location with that uuid

Infact when I am sending this request through the test module of openMRS then it is getting created but not through mirth connect.

Does it have to do anything with the errors that I am getting when I am viewing a patient Error after creating patient using REST