error when trying to login Bahmni using a user created in openmrs

good day i have created a user in openmrs and when i try to login bahmni using that user and credentials i get this message TypeError: Cannot read property ‘display’ of undefined

can anyone help me out please.

Hi morena,

Can you please share the stack trace to understand the problem better. And also what are the steps that you have followed to create user and credentials in openmrs.

stack trace? it does not giv me any errors in openmrs when creating users in openmrs, infact i can log into openmrs using those users but when i try to log into bahmni this error comes up:

TypeError: Cannot read property ‘display’ of undefined

Did you register user as a provider ? What are the roles assigned to the new user created ? “Bahmni-User” is mandatory for a user to login to Bahmni.

Please refer documentation link

yes i did give that role but no i did not tick the provider option letme try that

the privilleges are there in the picture

I think she did mean adding provider using this:

@morena Follow Step 6 under Create User

ok, but its fine i managed to create them and login successfully than you

one more thing im trying to upload modules in openmrs but its locked and i cant seem to find the runtime properties file so where is it stored in the bahmni-vagrant directory?

You can find the properties file @ /opt/openmrs/etc/ Change module.allow_web_admin to true. To reflect these changes, you have restart openmrs service using the command sudo service openmrs restart


in the local disk? or i execute it via the cmd?

you have to ssh into your vagrant box. From bahmni-vagrant folder run vagrant ssh

yes that i have done already

Now you can find the properties file @ /opt/openmrs/etc

when i execute /opt/openmrs/etc/ it just tells me that its a directory, from here what?

cd /opt/openmrs/etc/

1 Like

ok its syil saying the same thing,

Please share screenshot.

okay no now its fine, so after i navigate to that directory, i run this as it is?

Change module.allow_web_admin to true.

No, you have to open the file. vi For more commands on how to change the file, please refer using vi editor

ok its refusing to edit it, it cant erase the false.