Error when i add Jasper Module on OPENMRS

Hello,

Am getting below error when i add jasper module on openmrs version Version: 2.0.1

Error starting Module - Jasper Reports Module close Error while trying to start module Unable to load/find moduleActivator: ‘org.openmrs.module.jasperreport.JasperReportActivator’ Module: Jasper Reports Module

I am installing HMIS modules, openmrs-module-openhmis.commons, openmrs-module-openhmis.inventory, openmrs-module-openhmis.cashier, openmrs-module-openhmis.backboneforms and openmrs-module-jasperreports

How to solve this?

The Jasper Reports Module is not yet upgraded to support platform 2.0 I have just created a pull request to address it https://github.com/OpenHMIS/openmrs-module-jasperreports/pull/7 Hopefully @ibewes or any of the OpenHMIS team will merge it for you. :slight_smile:

Thank you let me wait for @ibewes

Please note that the OpenHMIS modules do not currently support the omrs platform version 2.x. This is something that we will be reviewing in early 2017.

Are you able to use omrs version 1.11 or 1.12 instead?

Thanks for this… I will look into your pull request and try and get in merged in quickly!

Thanks for reply

Can you share link for omrs version 1.11 or 1.12

Thank you

The Omrs platform 1.11.7 can be downloaded here: https://sourceforge.net/projects/openmrs/files/releases/OpenMRS_Platform_1.11.7/

I’m pretty sure that you can use omrs 2.4 with the platform 1.11 but I’m not sure about omrs 2.5. @dkayiwa Do you know if v2.5 works with pre-2.0 versions of the platform?

@ibewes the modules in reference app 2.5 should work in lower versions of the platform apart from legacyui and fhir

Hello, So i can download 1.11.7 platform and add modules of 2.5 reference app?

Yes, apart from only the legacyui and fhir modules.