Error Starting Logic Module

Av just checkout out to 1.9.8

Error while trying to start module Module requires version matching 1.7.2.17710. Current code version is ${parsedVersion.majorVersion}.${parsedVersion.minorVersion}.${parsedVersion.incrementalVersion}-${revisionNumber}

I have tried using both the logic module 0.5.2 and 0.5.1

@davie can you please give full details of what you are doing and full stack trace at pastebin.com

Am trying to setup openmrs for the first time, and am getting the above error. Steps: I have cloned the openmrs-core and checkout to 1.9.8, and mvn clean was also a success i relly dont know what the problem is. I have also tried to paste the logic module in the appdata/openmrs/module folder but still got the same error.

Are you running it from your IDE? If yes, try start it from command line.

1 Like

Yea am running it from my ide

@davie have you done what @dkayiwa suggested above ?

Yea have already done that. but still getting the same thing, have dropped the db and now am getting a different error.

this is the tomcat logs https://pastebin.com/LGyakwd5

@davie the Error logs suggest problem roots from .omod file naming Extension

ERROR - ModuleFactory.getModuleFromFile(447) |2017-10-13 14:57:54,600| Error getting module object from file logic org.openmrs.module.ModuleException: Module file does not have the correct ‘.omod’ file extension Module: logic at org.openmrs.module.ModuleFileParser.(ModuleFileParser.java:88)

Can you undeploy ,download a new file from repo,redeploy then restart the machine?