Error Exporting Data in Metadata Sharing Module

Hi everyone.

We have an error when we try to export some data in MDS. We can export concepts, person data, obs patients data successfully, but when we tried to export SqlDatasetDefinition or SqlCohortDefinition or SqlPatientDataDefinition it didn’t work.

For example, we have created 28 dataset definitions in reporting module and metadata sharing module shows SqlDataSetDefinition (All 0 selected).

Our version are: OpenMRS 1.9.3 Reporting Module 0.8.2 Metadata Sharing 1.1.9

Any suggestions?

Best regards.

1 Like

Unfortunately exporting any data from the reporting module is not supported out of the box at this point.

I did some work on adding support for that, but there was not enough push to test the solution. If you are interested, please follow up on and try installing

1 Like

I tried installing this module after making corrections on dependencies in in the pom file. But my question is how am I supposed to access it? through metadata sharing interface?

1 Like

@ningosi, the module supposedly adds “Report Definition”, “Data Set Definition”, “Encounter Data Definition”, “Person Data Definition” and “Cohort Definition” under exportable types in the metadata sharing UI. I experimented with it a long time ago so I’m not that sure anymore.

1 Like

Thanks! it does exactly the way you have explained. I just need to try import them and verify that all the objects are included in the package. Are planning to do a release of that module?

1 Like

Once you confirm it works, we can do a release :slight_smile:

1 Like

I tried creating a package, just to test this module after exporting the package via MDS module, on trying to import the package to another openmrs instance I get would you be having any clue what couod be stopping the import?

1 Like

I don’t have a clue. Please create an issue in the MDS module describing how to reproduce the error.

1 Like

Any time we make meta data using this module and try to import them, we always get this error Check line 61, 94 and 101. Is this related to a bug in the module or I am doing something wrong somewhere?

1 Like

I am having same issue on importing package that has been exported using reportingMDS.

  1. I exported package with reporting dataset on source I have reportingMDS module running

  2. When I trie to import the package on target with no reportingMDS it imports with no error but does not update any thing. And on Step 5 of package import it shows like the image below:

  1. When I trie to import the package on target with reportingMDS the import gives error pasted here. And on Step 5 of package import it shows like the image below:


  1. Do we need have reportingMDS both on source package and on target?
  2. How can I solve the posted error


1 Like

@eurico.jose, thanks for the detailed explanation. Yes, you need to have Reporting MDS on both source and target.

Could you please create an issue for the metadatasharing module in JIRA and attach the package to reproduce the issue? Next link the issue you created here.

1 Like

Hi @raff here is the created issues