Error compiling coreapps module


(Irene Nyakate) #21

Hello @tendomart I haven’t found the maven-license-plugin in the pom.xml of the coreapps module. Could you give me some leads? I tried checking but couldn’t find it and yet the error is still persisting. here is the error log


(tendo kiiza Martyn) #22

@irenyak1 sorry am late ,if not yet fixed ,after watching the project did you downgrade the coreapps version ?If so upgrade to the one of your Refapp Version.


(Irene Nyakate) #23

@tendomart, after watching the project I did not downgrade the coreapps instead the version I have i s 1.20.0-SNAPSHOT, but Ref App 2.8 has 1.11.1.


(tendo kiiza Martyn) #24

@irenyak1 locate this in your pom.xml

license-maven-plugin
3.0

license-header.txt

true

license-header.txt **/*.java

include
true within the “skip” child element.

within that element as indicated above.


(Irene Nyakate) #25

ok let me do that


(Irene Nyakate) #26

I have tried checking the pom.xml but can’t find the license-maven-plugin, could it be that it’s missing, is that possible?


(Irene Nyakate) #27

still geting same error after watching the module. https://pastebin.com/qgegK6Kz @k.joseph, @tendomart, @ssmusoke


(Kaweesi Joseph) #28

looks like coreapps is not started, ensure it starts first


(tendo kiiza Martyn) #29

@k.joseph No login page also displayed right from start of the "Protocol Handler ",could it be also that something was broken ?