emrapi 1.2.7 error running openmrs 2.3.0-SNAPSHOT

Tags: #<Tag:0x00007fe2e18f7458>

I’m new here and i build the openmrs-core-master copied the war file in to my tomcat webapp folder and run it and found out that i need the modules copied inside my USER/appdata/modules folder which i did but copying the emrapi-1.27.0.omod or any of its previous versions causes the application to break.

deleting the emrapi-1.27.0.omod from the modules folder fixes the problem but there are other modules which require the emrapi module… this is becoming a cause for a migraine for me right now… HELP

Here is the error log https://pastebin.com/MqiQiuXJ

@bitwise can u try to downgrade to openmrs 2.2.0 and see if the same error still persists, since 2.3.0 is still being tested

@ruhanga i think there is need to look at why emrapi is misbehaving in openmrs 2.3.0

1 Like

Thanks for the quick reply… works just fine on openmrs-standalone-2.2.0 but i wanted to make a few changes so i downloaded the source code from https://github.com/openmrs/openmrs-core.git and build the war file.

Is there any way i can find the source code for the previous versions?

the latest reff app version 2.10-SNAPSHOT that am going to release runs on core 2.2 .

the master branch always contans the latest code. The other branches always represent the previous versions. in otherwords checkout branch 2.2. However , if you think your commit will be merged to our community repo, youll stilll have to clone the master branch , and your commit will just be back-ported to the previous version.

tnx alot 2.2.1 worked perfectly… i guess the latest needs some fixing