Edit visit not working on the ref app.

Tags: #<Tag:0x00007f75150f8160>

Hi All

I was just trying to edit visits.

And I noticed that visits edit visit link is not working.I tried both qa-ref app instance as well as demo-openmrs instance to make sure it was not broken because of current changes.

Any idea ?

@ayesh

which one exactly ?

[Hi @tendomart

Its Edit Visit

1 Like

It is true ,i have tried https://qa-refapp.openmrs.org/openmrs/htmlformentryui/htmlform/editHtmlFormWithStandardUi.page?patientId=111&encounterId=1260& without much success.

Let me see if trying redeployment of demo server will work and get back.

@ayesh can you retry demo.openmrs.org it works for me .

https://demo.openmrs.org/openmrs/htmlformentryui/htmlform/viewEncounterWithHtmlForm.page?patient=227&encounter=2372&

Hi tendo

I am actually referring to visit not visit notes.

@ayesh I have run this Plan , try again with demo server and see what happens.

No tendo it’s something not working Hmm no idea maybe @dkayiwa can u help on this ?

@ayesh can you create a ticket for it?

Hi @dkayiwa

Sure will do it

Hi @ayesh

We have also encountered this issue with the Ref app, did you create a ticket for this or I open one?

Hi @samuel34

Nope I did not create a task samuel

We have had some early findings: This issue turns up if there is only one VisitType: Looks like its a metadata issue! It disappears if there is more than one VisitType in the system. See:

I’m not sure if this was by design or it’s just a bug?

cc: @mogoodrich, @ruhanga, @dkayiwa, @mksd

Looks like by editing a Visit, we only wanna change the VisitType. It’s the only editable attribute available for a visit? If so, then this was by design!!!

cc: @mogoodrich

In the PIH EMR we only have a single visit type, so I’ve never actually seen this functionality before. It does look like it was by design though as @samuel34 says… assumedly an implementation that did have multiple visit types needed a way to change visit type and so added this functionality.

1 Like

To make sense out of this, we need to hide the ‘Edit Visit’ link when an edit visit operation isn’t supported(When there is only one VisitType on the System)

@mogoodrich

@samuel34 I think this already happens… in the PIH EMR context we do not see the “Edit Visit” link.

@mogoodrich I’m worried it’s not as for the RefApp, I can see the void ‘Edit Visit’ link from the demo server: https://demo.openmrs.org/openmrs/coreapps/patientdashboard/patientDashboard.page?patientId=070f0120-0283-4858-885d-a20d967729cf&visitId=19192911-88d2-49f1-af5e-5ee5be62c77c

Created ticket: https://issues.openmrs.org/browse/RA-1648

cc: @mogoodrich, @mksd