Deploy openmrs-core to tomcat failing

I have built openmrs-core.

When I run mvn jetty:run the application works fine.

When I depoy the application to tomcat, I get a weird error about the database connection failing.

The OpenMRS folder has been created after setup when I run openmrs with mvn jetty:run. The folder has a file as well.

Any help will be appreciated.

James, you will need to share a link with the tomcat log.



James deGraft-Johnson

Good news.

I copied the runtime properties file from appdata\openmrs to the tomcat folder and it is now working.

The problem is I can’t compile openmrs-core with java 1.6. The version I deployed was built with java 1.8. I would really like to compile it with java 1.6.

I am waiting for some help from Wyclif on this.


I think you are mixing up things a little, master, 1.11.x and 1.10.x can all build and run on java 8 but master can’t build on anything older than 1.8

As for modules, currently we only guarantee then to build and run on java 6 and i think 7 but i can’t guarantee they would on java 8. So you have to keep in mind the project and branch you are working on to point it to the correct JDK.