Creating Appoinment - field 'Provider' is empty

When we’re creating appointment we can leave ‘Provider’ field empty. Is it a general assumption or should we get some error?

There’s not much documentation around Appointment Scheduling Module and it would be great if someone familiar with the module could write something up.

I can’t find an editable ‘Provider’ field when creating an appointment. When I go to Manage Appointments and search for a patient, then select service type e.g. Dermatology and choose a time block, the provider is already set and I cannot edit it.

  1. Click on ‘Appointment Scheduling’ and then click on '‘Manage Provider Schedules’
  2. Click on some day in calendar and there we can Create Appointment Block .

That’s true that there’s not much documentation, this movie on youtube is from 2013, in movie, version is different than version which I’m testing now. E.g. in new one we don’t have option to add appointment to patient or I just can’t find it. So I support the Rafał request about writing something more about Appointment Scheduling Module.

So it’s when creating an appointment block that you set a provider. A provider seems to be optional intentionally. I can imagine situations when patients are taken care of by whoever is available at the given time.

Shouldn’t there be some kind of “Default” provider for situations you are talking about?

Yes, you are intentionally able to create an appointment block without a provider, for use cases when you need to start scheduling appointments and know the time frames, but, for one reason or another, the provider is unknown. I believe you can add a provider to the block later on if need be.

I agree more documentation of the new functionality is needed. We did do a demo of the functionality on the developers call a few months back, and I believe there is a recording of it:

I don’t know if someone would have time to convert this demo into documentation? :slight_smile: I went ahead and added the above link to the main Appointment Scheduling wiki page.