Core Apps Module can't start - Deactivate modules

Hi everyone,

I’ve deployed the Platform 2.0.1 war on an Apache Tomcat 7 and I have installed the core apps and the legacy ui module in the modules folder (I have assumed that with these two modules OpenMRS could run).

The web application starts correctly but the modules aren’t able to initialize because, as I can see in the OpenMRS admin site, these modules need other modules to run.

The main issue: I have installed the required modules in order to run the two main modules said before (core apps and legacy ui) but the core apps module doesn’t start correctly and it says: “Unable to load/find moduleActivator: ‘org.openmrs.module.coreapps.CoreAppsActivator’ Module: Core Apps Module”.

Another issue: As I am doing all this in a raspberry pi (which has a low processing power) I want to ‘deactivate’ some of the modules which doesn’t contribute to me in order to decrement the processing time (the goal of the project is to build the OpenMRS into the raspberry and only be able to enter basic data such as blood pressure, temperature, pulse,… and with all the modules installed some basic querys take few minutes). I don’t know if there is a solution which allow to deactivate modules, to decrease the data to process by the server, but maintaining the dependences with core apps and legacy ui modules in order to be able to start these two modules

Thanks in advanced.

As you can see here, the coreapps module requires other modules which in turn may require other modules

As for the error you are getting of “Unable to load/find moduleActivator”, you need to use the latest release of the coreapps module.

I have downloaded the last release (coreapps-1.12.0.omod) but it stills not starting…

@asanchezf have you looked at the link Daniel sent, that mentions the other modules needed? E.g. have you also included those 7 other modules? (And I know that some of those have transitive dependencies also.)

Yes, I have all the modules included.

The thing is that when I was including the modules, firstly I included the legacy ui and the core apps module and when I open the app through the browser and went to the Manage Modules in the Administration ‘window’ I got a warning noticing me that I need other modules in order to run the core apps module. So, then I include the modules that were noticed to me in the warning and when I started again the application, some of the new included modules have other dependencies. I had to repeat the procedure until I finally got all the modules working except the core apps module, but this time, the warning was not the same as the previous times which said to me to install other modules, in this case the warning said: “Unable to load/find moduleActivator”

If you are still getting “Unable to load/find moduleActivator”, then just drop the openmrs database, delete the runtime properties file, delete all modules and download the reference application 2.5 modules zip file. Extract the modules into the modules folder and restart tomcat to run the setup wizard again.

I have completely reinstalled mysql after removing all the data, I extracted the modules, I run the setup wizard but still appearing the same error

Am assuming you do not have any custom modules and that you are using the latest reference application 2.5 modules. Can you paste tomcat log file contents at

Here you have all the log files because I didn’t know which one you wanted.






From another post, you seem to have gotten around this. Correct?

Not really, the problem with the core apps module stills there. In the other post I’m assuming that in a future I will have the core apps running.

The logs show that you are using some module versions that are not part of the reference application 2.5 It will be easier for you to just reinstall this and ensure that you are using the latest release of the reference application modules.

I have reinstalled all the modules that came on the zip file downloaded today from the page. Did you mean that? Or should I go to the page and take the newest modules versions of each module that I use?

The modules in the reference application 2.5 downloads page should be all you need.