Configuration Error

Hello, I am attempting to configure the Bahmni system. I have struggled with getting the Patient ID but I think I am over that hoop, however, when I attempt to save a new patient, I am getting the following error. It is so generic that I am unsure of where to look for a log file or any other clues. Can you please help?

Hello @dnelson,

You can find the logs at /var/log/openmrs/openmrs.log

How did you configure GEC ?

Can you please share a screenshot of the openmrs Manage Identifier Source page

thank you! i’m currently working from a remote location and the log file is 2+ gigs. I am unable to compress it and email it from here so I will send the information to you a.s.a.p. Is there a way to truncate the file?

I did attempt to configure GEC by basing it on an existing Bahmni ID type but I apparently did something wrong. What I would like to have is an ID starting with GEC and then 7 numbers, auto assigned…starting with GEC0000001. Thank you so much!

Remove the Regex Format for Patient Identifier Type Form

One way to do this is following the below steps

service openmrs stop mv openmrs.log openmrs.log.bck service openmrs start

After following the above mentioned steps, new file openmrs.log will be generated. Try to save the patient again, so that the logs get updated into new file (which will be smaller in size comparatively)

Okay, I am completely embarrassed and dumb to tell you I have messed the installation totally up :(. Ugh. I attempted to uninstall, drop the openmrs database and then reinstall using the steps outined at

Unfortunately, I believe I originally had V0.82 and now tried to install the recommended version V0.84. After many attempts, I just keep getting errors. I’m so sorry.

I love this system and really desire to learn it well but it is all new. YOU guys have done a wonderful job and I so appreciate your help!

So, what would you recommend? Is there a way to do a “cleanup” of all Bahmni files and start again?

Here i my current error when running bahmni -i local install skipping: [localhost] => {“changed”: false, “skip_reason”: “Conditional check failed”, “skipped”: true}

TASK [httpd : Stop httpd] ****************************************************** task path: /opt/bahmni-installer/bahmni-playbooks/roles/httpd/tasks/main.yml:55 ok: [localhost] => {“changed”: false, “name”: “httpd”, “state”: “stopped”}

TASK [httpd : Start httpd] ***************************************************** task path: /opt/bahmni-installer/bahmni-playbooks/roles/httpd/tasks/main.yml:61 fatal: [localhost]: FAILED! => {“changed”: false, “failed”: true, “msg”: “httpd: Could not open configuration file /etc/httpd/conf/httpd.conf: No such file or directory\n”}

NO MORE HOSTS LEFT ************************************************************* [WARNING]: Could not create retry file ‘all.retry’. [Errno 2] No such file or directory: ‘’

PLAY RECAP ********************************************************************* localhost : ok=65 changed=24 unreachable=0 failed=1

Traceback (most recent call last): File “/usr/bin/bahmni”, line 9, in load_entry_point(‘bahmni==0.1’, ‘console_scripts’, ‘bahmni’)() File “/usr/lib/python2.6/site-packages/click-6.6-py2.6.egg/click/”, line 716, in call return self.main(*args, **kwargs) File “/usr/lib/python2.6/site-packages/click-6.6-py2.6.egg/click/”, line 696, in main rv = self.invoke(ctx) File “/usr/lib/python2.6/site-packages/click-6.6-py2.6.egg/click/”, line 1060, in invoke return _process_result(sub_ctx.command.invoke(sub_ctx)) File “/usr/lib/python2.6/site-packages/click-6.6-py2.6.egg/click/”, line 889, in invoke return ctx.invoke(self.callback, **ctx.params) File “/usr/lib/python2.6/site-packages/click-6.6-py2.6.egg/click/”, line 534, in invoke return callback(*args, **kwargs) File “/usr/lib/python2.6/site-packages/click-6.6-py2.6.egg/click/”, line 17, in new_func return f(get_current_context(), *args, **kwargs) File “/usr/lib/python2.6/site-packages/bahmni-0.1-py2.6.egg/”, line 50, in install return subprocess.check_call(command, shell=True) File “/usr/lib64/python2.6/”, line 505, in check_call raise CalledProcessError(retcode, cmd) subprocess.CalledProcessError: Command ‘ansible-playbook -i /etc/bahmni-installer/local all.yml -vv --extra-vars ‘@/etc/bahmni-installer/rpm_versions.yml’ --extra-vars ‘@/etc/bahmni-installer/setup.yml’’ returned non-zero exit status 1 [root@localhost GechUser]# yum list installed | grep bahmni bahmni-certs.noarch 1.0-48 @bahmni
bahmni-installer.noarch 0.84-204 @/bahmni-installer-0.84-204.noarch [root@localhost GechUser]#


No issues… We are always ready to help. Thanks for your interest in Bahmni…:slight_smile:

Please follow the below steps to fix the issue.

yum remove -y httpd

bahmni -i local install

Thank you @sravanthi17! I ran that and getting same error!?

Can you please check if the httpd.conf is present at /etc/httpd/conf.d If yes, please paste the contents of the file

It appears to exist as a “shortcut” but when I attempt to open it:

delete that file

yum remove httpd bahmni -i local install

@sravanthi17, you are the best, seriously! such and easy fix when you know what you’re doing!. Thank you so much…I’m back up and working. Have a great day.


Steps to solve the installation failure at Starting Httpd.