ClinicalVisit test failing on my side at the point of saving a note

Hello Friends, I am working on this Ticket and before adding any of my changes, I updated master in the Qaframework module on my machine then created a branch RATES-220. After doing this I run this command npm run refapp2ClinicalVisit to start this particular test that I have pulled from master, however, everything else runs well until the test tries to save the visit note. I am getting this error log as per the surefire report and this log as per my terminal , then on the UI at the point the test breaks, I get this notification as in the image below.

Please help me with this blocker. Thank you. cc @kdaud , @sharif , @dkayiwa , @ibacher

Which version of refapp are you running on your machine?

@kdaud , I am running Refapp 2.x

could you specify the specific version of refapp?



you need to update your server with the released version of RefApp 2.12.0 than using a SNAPSHOT!

1 Like

@kdaud I built a fresh server instance for RefApp2.12 but it still returns the same error as above.

does this occur when you change the browser engine to chrome?

Hi @kdaud I finally installed chrome 90 and the test started running but it fails at the same point as here. What could be the issue?

Saving the visit note has a problem. I have also tried to do it manually but it still brings the same error. cc @kdaud @sharif

	at ✽.the system adds the note into visit note table(file:///media/irynah/DATA/0PROJECTS/OpenMRS-projects/openmrs-contrib-qaframework/src/test/resources/features/refapp-2.x/14-clinicalVisit/clinicalVisit.feature:43)

Results :

Tests in error: 
  Clinical Visit(Clinical Visit Management): Expected condition failed: waiting for org.openmrs.contrib.qaframework.helper.Page$1@5e7c48b0 (tried for 120 second(s) with 500 milliseconds interval)(..)

Is it also failing on master branch! Do you mind sharing the whole error log because it’s passing on master probably the problem is with your local environment

@sharif maybe the problem is with my local environment, however if is failing also on master but at a different point. irynah@irynah-HP-Spectre-x360-Convertible-13-aw0xxx:/media/irynah/DATA/0PROJECTS -

@sharif I have realized that on master it is failing with firefox but passes well with Chrome.