Click package error while installing bahmni in centos 6.8

Hi , I’m a newbee, could you please help me with following queries

  1. Can bahmni be installed in centos 6.8
  2. I see following error while installation

Processing dependencies for bahmni==0.1 Searching for Click Reading http://pypi.python.org/simple/Click/ Download error: – Some packages may not be found! Reading http://pypi.python.org/simple/Click/ Download error: – Some packages may not be found! Couldn’t find index page for ‘Click’ (maybe misspelled?) Scanning index of all packages (this may take a while) Reading http://pypi.python.org/simple/ Download error: – Some packages may not be found! No local packages or download links found for Click error: Could not find suitable distribution for Requirement.parse(‘Click’)

Thanks

Hello,

We recommend 6.7 which is tested. Can you manually try pip install click. Please share the output after that.

it successfully installed the pip.
Then i executed install bahmni


Using /opt/bahmni-installer/bahmni-playbooks/ansible.cfg as config file ERROR! Syntax Error while loading YAML.

The error appears to have been in ‘/etc/bahmni-installer/setup.yml’: line 17, column 19, but may be elsewhere in the file depending on the exact syntax problem.

The offending line appears to be:

    .navbar-fixed-top {
        height: 91px;
              ^ here

Traceback (most recent call last): File “/usr/bin/bahmni”, line 9, in load_entry_point(‘bahmni==0.1’, ‘console_scripts’, ‘bahmni’)() File “/usr/lib/python2.6/site-packages/click/core.py”, line 716, in call return self.main(*args, **kwargs) File “/usr/lib/python2.6/site-packages/click/core.py”, line 696, in main rv = self.invoke(ctx) File “/usr/lib/python2.6/site-packages/click/core.py”, line 1060, in invoke return _process_result(sub_ctx.command.invoke(sub_ctx)) File “/usr/lib/python2.6/site-packages/click/core.py”, line 889, in invoke return ctx.invoke(self.callback, **ctx.params) File “/usr/lib/python2.6/site-packages/click/core.py”, line 534, in invoke return callback(*args, **kwargs) File “/usr/lib/python2.6/site-packages/click/decorators.py”, line 17, in new_func return f(get_current_context(), *args, **kwargs) File “/usr/lib/python2.6/site-packages/bahmni-0.1-py2.6.egg/bahmni.py”, line 46, in install return subprocess.check_call(command, shell=True) File “/usr/lib64/python2.6/subprocess.py”, line 505, in check_call raise CalledProcessError(retcode, cmd) subprocess.CalledProcessError: Command ‘ansible-playbook -i /etc/bahmni-installer/local all.yml -vv --extra-vars ‘@/etc/bahmni-installer/rpm_versions.yml’ --extra-vars ‘@/etc/bahmni-installer/setup.yml’’ returned non-zero exit status 4

Thanks

What are the contents of your setup.yml ?

Are you following this documentation ?

yes, i did follow the same documentation. Did i miss anything .

setup.yml should contain the following lines

timezone: Asia/Kolkata

implementation_name: default

selinux_state: disabled

If your file is not similar to this, please add the above lines and run bahmni install

Thanks, this sequence helped me solve the error .